Yealink Forums

Full Version: Yealink T48G Won't Turn On (No Power)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I was off for a couple of days and returned to my office, only to find that my Yealink T48G phone was completely off. I took the power adapter (YLPS052000B-US) and tried it on another T48G, and that phone powered up without problem. I then tried a switching power adapter from another T48G (even on a different known working power plug), but the phone still won't turn on at all.

Do you have any suggestions?

It is less than a year old. I contacted the seller and they say they only warranty for 90 days and I have to go through the manufacturer. I tried finding an RMA section from Yealink.com, but am unable to do so.
Dear Bill,

Thank you for your detail info.
About your problem, it should be a hardware issue.
Also, can you kindly tell me where you buy the phone? What is your area?
Please provide the SN and the MAC of the phone to me. Thank you.

With the detail info, our sale engineer will help you to do RMA.
(03-07-2017 07:48 AM)Lucia Wrote: [ -> ]Dear Bill,

Thank you for your detail info.
About your problem, it should be a hardware issue.
Also, can you kindly tell me where you buy the phone? What is your area?
Please provide the SN and the MAC of the phone to me. Thank you.

With the detail info, our sale engineer will help you to do RMA.

Hi Lucia, the information is the following.
Serial Number: 8109316031103571
MAC: 001565A777E2

We are in Kansas and purchased it from Amazon.com. The seller was U.S. Telecom Source.
Yes, thank you for your confirm.
Our sale engineer will contact you and help you to do RMA.
(03-13-2017 01:50 AM)Lucia Wrote: [ -> ]Yes, thank you for your confirm.
Our sale engineer will contact you and help you to do RMA.

Thank you.
Reference URL's