Yealink Forums

Full Version: DHCP issue on Yealink phones with HP Switch HP2920
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello everyone,
We’ve got a new HP Switch HP2920 – 24 - layer 3.
We have configured the following simple 2 VLAN’s:
= = = = = = = = = = = = = = = = = = = = = = = = =
hostname "HP-2920-24G"
module 1 type j9726a
snmp-server community "public" unrestricted
ip address dhcp-bootp
vlan 1
no untagged 4,10-20
untagged 1-3,5-9,21-24,A1-A2,B1-B2
ip address
vlan 50
name "VLAN50"
untagged 4,10-20
ip address
ip helper-address
no dhcp config-file-update
no dhcp image-file-update
password manager
= = = = = = = = = = = = = = = = = = = = = = = = = = = =
VLAN1 – 20.1.10.X - default DATA
VLAN 50 – 20.1.50.X used for the IP Telephony.
DHCP server - [Windows server 2008 R2]
Yealink phones T22 and T42G.
Switch port 1 – is going to FW interface for default VLAN 1.
Switch port 4 – is going to FW interface for VLAN 50.
Before I will test the provisioning with 3CX PBX we have the next issue:
Even though I have set up “ip helper-address” for Vlan 50, Yealink phones are NOT getting IP addresses on VLAN 50, but are getting IP’s on default VLAN 1.
The computers are getting DHCP IP addresses on Vlan 1 or Vlan 50. No issue with the computers.
I have tried to add voice command on the VLAN 50 and didn’t work.
I have tried to disable the LLDP on Yealink phone but didn’t help.
Can anyone faced the same issue before?
Thank you very much in advance.
Hi Crizz,

What's the firmware of T22 and T42G?
When you fill a VLAN 50 to phone manually please make sure that the LLDP is disabled at that time.

And will phone get an ip address on VLAN 1 when you fill VLAN 50 manually?

Looking at your 2920 config you have this list...
vlan 50
name "VLAN50"
untagged 4,10-20

Where is the tagged?
If you are wanting to put the phones on a tagged vlan which is what it sounds like you would want to have those ports "Tagged". Here is what i would normally see

vlan 50
untagged 4,10-20
tagged 1-3,5-9,21-24,A1-A2,B1-B2
ip address
ip helper-address

If you are unsure how to get this going on the 2920 PM me and i will give you a hand. Got probably hundreds of HP switches out there so shouldn't be a issue what you are looking to do.
Hi James,
I even upgraded to for T22P and for T42G.
The LLDP is disabled on the phones. I’m not using VID enable on 50 on the phones yet. The VID is disabled on the phones and some switch ports are untagged on vlan 50 so it should get DHCP. Are getting DHCP ONLY when the phones are connected on the untagged ports on vlan 1.

Hi tsukraw,
The phones should be able to get DHCP when connected on untagged ports on vlan 50 with VID disabled on the phones side. Are getting DHCP only from untagged ports on vlan 1, this vlan 1 is the VLAN where the DHCP serves is sitting. This is not relay / ip helper issue? I don’t think is it as long as the computers are getting DHCP from from vlan 50. I did some wireshark captures on mirrored port and I noticed that the DHCP server is issuing the IP from vlan 50 but the phone cannot receive or accept the knowledge of IP offer.
Another test I did and it works: I allocated a new network card for the DHCP server [IP:] and I connect it to the untagged port on VLAN 50 on the SW and then I disabled the IP helper address form Vlan 50. It this way the phones managed to get DHCP from VLAN 50. But this is not best practice because I will have many VLANs later on and I need to get DHCP on the phones for troubleshooting. I just want this SW to do the job if it’s a SW issue. Because this SW will be the main SW. later on another 8 SW’s will be uplink connected to this one.

Thank's for replying guys !
Hi guys,
Other ideas ?
Hi guys,

As per first above configuration I did some package capture with Wireshark on mirrored port of one of the phones ports connected to and I noticed that the DHCP server is issuing IP’s on VLAN 50 but for some reason the phone doesn’t receive or can’t accept the offer of new IP, OR the Switch is blocking those packages. DHCP is not doing any entry on the released IP list but is trying to release a valid IP. Is probably waiting for phone to accept it first. This is what I understood from the wireshark capture. I don’t know if its from the SW area or from the phone.
I just remind that this issue it happens only for the yealink phones, all other devices are getting DHCP on the VLAN 50. And also the phones are getting DHCP on VLAN 1 (the DHCP is on this vlan).
In production, the main SW is and HP POE v1910 layer 3 and this is working with same configuration. And the yealink phones are getting DHCP.
Shall I open a ticket on Yealink or with HP? This issue is very frustrated, I couldn’t find anything anywhere!

Other ideas?
Thanks in advance!
Hello Crizz,

Can you please upgrade T42G to V80 and do the follow test:
T42G V80 firmware:

1. Login into phone web interface, enable "Span to Pc" under Network advanced. Set the syslog level to 6 under Setting-> Configuration.
2. Connect PC to phone PC port and start wireshark, reboot phone. After phone get an ip address, export the pcap trace and syslog.
3. Re-start wireshark in PC. Enable/disable LLDP, phone will reboot. After phone get an ip address, export the pcap trace and syslog.

We can check what phone receive and react to packet from switch.

Reference URL's