Yealink Forums

Full Version: FIXED: Host is not a tftp server
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I'm attempting to provision a T23G via TFTP with FreePBX. I can see the TFTP request come in on the TFTP server, and it requests its two config files, however the phone is not updating with its config.

I downloaded the log from the handset itself and it is full of TFTP errors like below:

Quote:ATP [399]: ATP <3+error > tftp to file failed, code = -16, msg = Host is not a tftp server, retry = 1

I can't understand this. If the handset is requesting the files via TFTP, I can see the files being provided to the handset on the TFTP server, then why does the handset think it's not a TFTP server?

I've tried this with a couple of handsets now, one being a T22P, and I'm getting this error in all of their logs, each time though I can see the files being requested on the server.

What would cause the handset to not recognise a TFTP server as a TFTP server? If I can understand this, I may be able to get closer to resolving this.

Thanks for anyone's help they may be able to offer. I'll continue playing around with it in the meantime.
can you send the whole log of phone to us, so we can check more.
Hi Karl,

Happy to do this, but can you PM me an e-mail address to send the log to? The forum e-mail system is timing out on me.
You could first try to get the file with a plain tftp client. On my Ubuntu system, the command is like
tftp your.tftp.server -c get your_file.cfg
(With a different client, the options may be different)
Thanks for that tip mivk.

I used the TFTP client feature in Windows and tried to download a file. I'm seeing the request come into the TFTP server on FreePBX multiple times (with no errors), but I'm not getting the file back.

This could be why the phone is reporting that it's "not a TFTP server", as it's not getting anything back from its request. This is starting to look like it's a TFTP server issue on FreePBX rather than the phone.
I've further confirmed this by spinning up a FreePBX server as a VM at home and TFTP is working fine on this one with a Yealink handset.

I'll do some more investigating around that and report back with my findings in the hope it will help someone else out!
Just a quick update.

I've been reading up on the TFTP protocol, and it's not firewall friendly. The issue appears to be firewall related.

Rather than using TFTP, I'm trying out provisioning via other protocols. HTTP provisioning is working fine (ultimately will use HTTPS and/or authentication).

So, the phone responding with 'Host is not a TFTP server', appears to be the error you get when no response is received by the phone from the TFTP server. The way I'd try and explain this is, if your phones are behind a firewall, they request a TFTP connection on UDP 69, but the file transfer can then take place on a random (but dynamically negotiated) UDP port. You'd have to NAT all UDP ports through to your phone for TFTP provisioning to work.
Indeed, I did test this by NAT'ing all UDP traffic from the server to the phone, and it did actually provision via TFTP. Obviously unless you only have one phone on your internal network, with an internal static IP, NAT'ing traffic from one server to multiple phones is not possible, so in the scenario where your TFTP server is on a separate network to your phones with a firewall inbetween, an alternative provisioning protocol (that uses only a single port for everything - FTP probably wouldn't work either), is the way to go.

I'll mark this as 'fixed' as the issue wasn't really phone related (but the error in the logs didn't make much sense at the time). Hopefully this will help someone else out who's stuck.

Perhaps a more meaningful error in the logs such as 'no reply from TFTP server' would be appropriate?
Great to hear that this problem fixed. I check the complete log.

TFTP<5+notice> tftp open begin, host:, port:69, remote_name:00156583cb03.cfg
TFTP<6+info > Send Request Packet
Nov 19 23:54:02 ATP [399]: ATP <3+error > tftp to file failed, code = -16, msg = Host is not a tftp server, retry = 1
Nov 19 23:54:02 ATP [399]: ATP <4+warnin> Download mac.cfg fail

From the first line, we can know the tftp server address is and the port is 69.
Request file is 00156583cb03.cfg. Then the third line, we can see that phone fail to download the mac.cfg file.
The phone send TFTP request packet, and phone don't receive any replay, the phone show error message ' Host is not a tftp server'.

Sound 'no reply from TFTP server' it's better than ' Host is not a tftp server', I will give suggestion to our RD.
Reference URL's