Yealink Forums

Full Version: DTMF tones from T-20 not recognized
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a T-20 running firmware When I call a number on our PBX and try to select an option in the auto-attendant, the IVR does not respond to the key presses. I checked the PBX's logs and confirmed the PBX did not receive any DTMF tones.

I've tried every combination of DTMF settings on the phone, but none work.
Hi Chris,

May I know what's your PBX server? All three DTMF type(sip info, RFC2833, inband) can't work?

Please have a try of V73 firmware:

We are running Elastix v2.40 (based on freepbx 2.8.1 and asterisk 1.8.20). I tried all DTMF types but none worked.

Is v73 publicly available? I don't see it in your ftp. We use RPS, will this firmware support it?

I tried the new firmware but it didn't fix the issue. I tried all DTMF types on the phone.
Yes, it's publicly available.
All V73 firmware support RPS.

T20 V73 release web page:

Thanks James. Unfortunately it didn't work. Any other ideas for me to try?
Can you please get a pcap trace/level 6 syslog/config.bin file? Will send it to our R&D for an analysis.

For how to capture these files:

Reference URL's