Yealink Forums

Full Version: DHCP issues with V73
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Just tried upgrading one of the t-22 phones we have in the office to
Upon reboot, the phone does not want to get the IP address via DHCP, and just stays on the screen saying "obtaining IP address".
I have left it on here for longer than 10 minutes, the message doesnt go away.
I tried restarting the phone several times, no effect.
I tried connecting a power supply to the phone, then disconnecting the network cable and plugging it back in - the page refreshes and the phone obtains the new IP via DHCP. This seems to be the only trick to get DHCP to issue an IP to the phone.

I then tried both .50 and .40 versions of v73 firmwares you have available, both are exhibiting this problem, tested on several t-22 phones. Each time after the firmware update and a reboot the phone will get stuck on "obtaining IP address" screen.

I then downgraded the phone to and upon a reboot the phone obtained the IP via DHCP without issues.
Hello ,
We have tested it here with two T22s but both them can work well, after upgrade to , it can obtain the IP address when back to idle states, if reboot the phone again, it can obtain the IP address as well.
in this case, would you please send us config.bin file, pcap trace and level 6 syslog that we can submit them to the R&D for debug ?
since the phone can work well with version , please send us the same information about V72 as well.
please send them to
Best Regards!
Just one idea.
Do you have Option 66 configured on your DHCP server?
What device is dealing out your DHCP?

We saw a similar issue on V73 where our dhcp had option 66 and the phones would not obtain a IP for whatever reason. We removed option 66 the issue went away.

We experiences this at 3 different locations. Each of the 3 were small installs a dozen or so phones so we jsut left option 66 out and if they get a new phone just manually put in the provisioning URL.

Let i said just a thought to try.
We didn't use the option 66 in the DHCP server normally, the option 66 used when the phone need do auto provision from DHCP server, in this case, the phone will go to auto provision from the Ip address configured in the option 66.
Best Regards!

I think you need to test with a larger sample of phones. We have tested the V73.0.50 on the T26 phones and we find about 2 in 10 exhibit this problem of NOT getting an IP address. They just sit on the screen saying "obtaining IP address". In particular we were testing on our POE switch... so pulling the Ethernet cord and plugging it back in didn't help. We too had to plug in a power brick, pull the Ethernet, plug the Ethernet back in and then it would get an IP address.

It's like this new firmware has a very small window in which to grab the DHCP address and some phones just don't come on line in time.

We downgraded all of our phones in the field to a v72 build.

Please let us know when you have this issue fixed on V73.
Thanks for your information .
in this case, would you please send us config.bin file, pcap trace and level 6 syslog that we can submit them to the R&D for debug ?
since the phone can work well with version , please send us the same information about V72 as well.
You can refer to below link for how to catch these information.
Best Regards!
Hiya, this happens with latest firmware too.
Phone will stay idling saying "obtaining IP address" forever.

Fix: If pull the lan cable from the phone, and plug it back in - it will pickup the ip address and start working. If i reboot the phone, back to "obtaining IP" until you disconnect the cable and plug back in...

I found this happening on our corporate network as well as our home user who has a normal fibre router at home.
Have same issue -> No IP with DHCP at latest firmware.
Downgrade to latest v72 and DHCP works again.

Tested witd option 66 disabled -> No IP
Tested with DHCP and power supply -> No IP
Manual IP with VLAN -> Phone is reachable.

T46G new
Cisco POE-Switch with vlan 10(DHCP) untagged and 200(voip) tagged
Phones get ip from dhcp in untagged lan 10 with tftp-information from option 66. Autoprovisioning set phones to vlan200 with new static ip. That works with 15+ phones at v72.
Same issue with latest -> No DHCP! No sollution???
Hard work to find out the error! Disabled the "Smartport"-Feature in Cisco-Switch, disable lldp on Phone and now it runs!

I dont know what the problem is... in old firmware there was no problem!

If i set phone to vlan200 and manual ip, i reach the phone.
If i disable vlan configuration and set IP in our pc net (which is normaly no problem because untagged vlan10) i can't reach the phone.

The Cisco switch smartport-feature set additional port-settings, but if i manual set this options... no problem.

interface fastethernetXX
port security max 10
port security mode max-addresses
port security discard trap 60
macro description ip_phone_desktop

Only setting i not tested was " spanning-tree portfast".

Why is lldp standard enabled? Should be disabled!
Pages: 1 2
Reference URL's