Yealink Forums

Full Version: Click to dial from Netsuite (solved)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

We have recently switch our system to Netsuite and there is an ability to use the phone through URL.

I so tried to set for our T22P and T32P the command line but the system is picking the phone, ring, but does not pick the number from the software

I tried various way but never was able

here is a example for the T32P


the phone show %number% and not pick the netsuite number.

if I check what it does when click it link to something"jNLDial('+331xxxxxxxx')

Any help/ideas would be appreciate
The T38 and VP530 use a different format from the T2x series.

T38 and VP530


Navigate to "Yealink -> Phone -> Features -> API Security -> Trusted Action URI Server List" and add the IP address of the host you will use to dial. The first time you try to place a call, a dialog appears on the phone display asking whether to allow remote control, press "OK" (firmware version
Phone Call Wizard for Hire. Phone Amego: The Missing Mac Telephony Bridge
Hello psichel,

thanks for your explanation, I did this and yes the number is dialing correctly.
My problem is more how to pick the number from the netsuite software, I might miss explain
Indeed , if I enter the line like you said, yes, the number is dialing correctly , either for the T22 or the T32.
What I can't get is the command line which allo the system to pick the number and dial it. I tried %number% but it does not copy/paste the number from the software.
I tried a firefox plug in call telify which work correctly, the syntax is number=%0 to pick the number. I tried of course for netsuite without success .
I'm strungle with the correct syntax to "cut/aste" the number and dial it. the re is a java script but it does this : "jNLDial('+331xxxxxxxx') . If I could catch this and only get the number, our problem would be solve
I solved the issue Smile I was not choosing the correct wording to pick the number from Netsuite. %number% did not pick the left mouse click. After few check and test, {number} worked !
Hi, you can try out Callinize and their click to dial feature should work great for you. They have integration for Yealink and Netsuite and will take only a few minutes to set up.
Hello guys! Here's another add-on you can explore for CTI with Yealink. It's called Tenfold, and it supports integration between Netsuite-Yealink.
Reference URL's