Yealink Forums

Full Version: Autoprovision to include OpenVPN Configuration
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

I want to auto provision all of our phones with a VPN configuration.

currently if i upload the tar file and reboot, it works fine, but I cannot get it to do this as part of the auto provision.

I have my (first) auto provision set as follows;

firmware.url =
network.vpn_enable = 1
openvpn.url =$MAC.tar

Now I can see that on the TFTP Server it grabs all the correct files, including the VPN tar configuration, but after it reboots, the VPN is enabled, but the box underneath is blank (it normally says vpn.cnf) and the VPN doesnt come online.

If i browse and upload the tar file, it works fine.

What am I doing wrong?
hi Matt

would you mind upgrade to the newest firmware and test again :

auto provision sentence : =1
static.openvpn.url =

if all the above solution can't solve your issue, please provide us the trace file for future analysis,trace file including pcap file, config bin and syslog file , we need pcap file to check the communication of phone and server side , we need syslog file to know what happened to phone side , and we need config file to check if any configuration is missed, so we need three of them provide at one time.

as the phone will reboot , then it is advised to use a wireshark tool to get the pcap file , for how to download the tool and use it , please refer to the link below :

for the syslog, please export it to server side , before phone reboot , you can refer to the guide download from below link :

for the config.bin file , please refer to the FAQ below :

after you collect all the three files, just send them to me ASAP

let me know if any question


Hi Michael,

I have tried on this and the 80 firmware and both have the same results.
it just doesnt seem to add the TAR file to the phone, if i manually log in to the handset, the VPN is enabled, but the box below is empty.

i know that the TAR format is correct, because if i upload the file it then works fine.

I have tried sending the file via HTTP and TFTP, both ways i can see either the file being sent or requested and sent ok to the handset, but it doesnt reboot with the VPN configuration file uploaded.

I can see the following error on the phone syslog;

ATP <3+error > md5 file(/config/openvpn/$MAC.tar.MD5) do not exist
Just an update, i now have this working fine i moved my tar file to a folder named the MAC address of the unit and then change the provisioning link to openvpn.url =$MAC/openvpn.tar
I'd like this also
Reference URL's