Yealink Forums

Full Version: Trying a factory reset from the base unit and nothing happens
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Brief background on why I'm trying a factory reset. The phone had been working for 1 day and the web interface was working fine. I attempted to log into the web interface and the default username and password of "admin" did not work. I never changed it to begin with.

Since I could no longer log in with it I decided to try the factory reset from the base station by holding down the paging button and plugging the power back in. The unit does what the instructions say it's suppose to do by lighting up all of the LEDs starting from the bottom up, but it just sits there. I've left it alone for an hour on one attempt and still nothing. Just sits there with all LEDs light. I then unplug it and plug the power back in, connect the ethernet cord and it goes through it's initialization. It gets an IP address but my phone is no longer registered. I go through the process of registering it and it does it successfully using the default pin "0000". I mention this since when I try to do a factory reset from the phone and try the default pin of "0000" it says the pin is incorrect, but I just I used it to register the phone unless its a different pin. In any case, the phone is registered, the base gets an IP address, the web interface pops up with the login form but the default username and password "admin" do NOT work. I also notice that the base does not reset at all to defaults since it still works with my VoIP provider. Strange.

How else can I reset the base to factory defaults or am I missing a step somewhere?

Hi Kenny,

In reseting operation when all of the LEDS light up you can unplug it right away. There is no need to wait so long.
Can you try a hard reset again? If the problem persist please let us know your base firmware?

Hi James,

Did another base reset and immediately unplugged the power when all three lights turned solid green. It rebooted. Had to re-register the handset with "0000" pin. After phone registers, it initializes provisioned with the info from our VoIP providers so right off the bat I know the base has not done a complete factory reset. Base gets an IP address and I am able to access the admin portal, but default username and password do not work still. Unless there is a menu option to get the firmware of the base from the handset I can't find out what that is since I can't log into the web interface.

Hi Kenny,

You can know the base firmware from handset.
Press OK-> Status-> Base

Maybe it's provisioned after reset.
Can you try these steps:
1. Unplug network cable.
2. Do a facotry reset.
3. Power it up without a network cable.
4. After phone finishing booting, plug the network cable.

Or you can also check with your pbx service provider.

Ok, now this is weird.

So after reading your last comment about unplugging the network cable, I simply just blocked all communication from the base going out through the internet on my firewall then:

1. Did base reset by holding down the paging key and saw all the lights turn green.
2. Power cycled it.
3. Re-registered the handset at which point I noticed that it now said "H1" and not the last four digits of the number from Telesphere provisioning
4. Did a base restart from the handset using "0000" just to see if it worked and it did
5. Logged into the web interface with default "admin" and "admin" and it worked.
6. Went to the Phone - Auto Provisioning section and noticed that there was nothing in the "Provisioning Server" field. Entered in a bogus url "" and saved it just to make sure it would over write the Telepshere info.
7. Change the admin password and re-logged back in with the new password of "1234"
8. Changed the Pin and tested it by restarting the base from the handset with new pin of "9876"
9. Added back the IP address of base on the firewall to allow outgoing communication again
10. Rebooted base
11. When handset synced back up I notice that it now said the last 4 digits of the Telesphere demo number I'm testing
12. Cannot access admin page with "admin" and new password of "1234" or old password "admin"
13. Cannot do a base restart from handset with "9876" or old pin of "0000"

So from the looks of it, even when you do a factory reset of the base it still retains the "Provisioning Server" setting of the initial value you set which in my case was pointing to and even if you try to over-write after a base reset it it still goes to this url. This has to be a bug.

I'm guessing also that when Telesphere auto-provisions the base it can set the Admin password and pin during this process which I will discuss with them but that's just a side note, unless this shouldn't be the case as well.

Hi Kenny,

It should be a RPS process.
If a firmware support RPS then it will go to request a provision URL from Yealink RPS server in reboot and do an autoprovision. The RPS will be automatically turned off once there is a successful provision.

So if you fill a real provision server and phone do an autprovision then it won't go to RPS process in reboot.
Now, you can manually do an autoprovision after reboot to disable RPS or ask telesphere to change the configuration file in their side.

The RPS feature will provide huge convenience in mass deployment since all phones can be plug and play.

Reference URL's