Yealink Forums

Full Version: Trying to unbrick base.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I had a problem where the phone stopped working. My first step was to reboot the base, but once it was powered back up, the handset couldn't find it and I couldn't access the web admin UI.

I checked my router, and it did not appear to be taking an IP address from the DHCP server.

To try and bring it back to life, I followed the recovery guide I found on this forum, (via Tftpd32). However if I power up the basestation, only the power LED is lit and it does not obtain an IP address (as shown in the "DHCP Server" tab in Tftpd32).

If I power up the basestation while holding down the paging button, all three LED's light up and I see W5X.bin and W5X.rfs get transferred:

Connection received from on port 1142 [30/12 15:53:57.069]
Read request for file <W5X.bin>. Mode octet [30/12 15:53:57.069]
OACK: <timeout=5,blksize=1468,> [30/12 15:53:57.069]
Using local port 61578 [30/12 15:53:57.069]
<W5X.bin>: sent 1032 blks, 1514044 bytes in 0 s. 0 blk resent [30/12 15:53:57.849]
Connection received from on port 2047 [30/12 15:53:57.989]
Read request for file <W5X.rfs>. Mode octet [30/12 15:53:57.989]
OACK: <timeout=5,blksize=1468,> [30/12 15:53:57.989]
Using local port 58749 [30/12 15:53:57.989]
<W5X.rfs>: sent 5715 blks, 8388608 bytes in 5 s. 0 blk resent [30/12 15:54:02.279]

However the "DHCP Server" tab still doesn't show anything and the W52P.rom file is not transferred.
Hi Simon,

Can you have a try of hard reset.

1. Disconnect the power adapter.
2. Long press the paging key and reconnect the power adapter.
When base station finishes reset, the power indicator LED, network status LED and registtration LED illuminate in sequence. System PIN and all individual setting are reset to factory defaults.

When you do a facotory reset the DHCP server and TFTP server are set up in a same PC or two PC?

Thanks for your reply.

I tried a hard reset and it makes no difference (it doesn't pick up an IP address).

For the attempted reset, I have the DHCP server and TFTP server on the same PC.
Reference URL's