Yealink Forums

Full Version: 3CX Android Rejected call Auto Answers on T48
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a weird problem that came up as I am testing our system to go live.

On my extension 100, I have the 3cx Phone app installed on my Android as well as a T48 assigned. When I receive a call to my extension my 3cx android app and t48 ring. If i reject the call on the android app, the t48 will automatically pickup the call on speakerphone.

I have checked and auto answer is turned off. I have also checked the auto forwards settings, and all look to be correct. I factory defaulted the phone and reapplied the latest provisioning template from 3cx so I know I had a "Fresh" build. I still have the same issue.

I have tried this on another extension with the same 3cx Android app and T38's and there seems to be no issue.

What am I missing?????

Thanks in advance

I have done a little more testing:

I have 1 channel voice gateway hooked up, when a make a call from that gateway to my extension and reject the call, my desk phone continues to ring as it should. When I call from another extension (T38) and i reject the call, the T48 goes to speakerphone.

I removed the T48 and swapped in an extra T38 I have and it functions as it should from all extensions. (I reject the call and desk phone continues to ring)

So it would seem this is an issue with the provisioning template for the T48? I will say I was running in demo mode until a week ago when I purchased the full license for v12. When I did that I upgraded all the provisioning templates that were available, this issue COULD have started then.

What's the firmware of T38G and T48G?
Phone may receive an invite message carrying answer-after=0 header which trigger it to answer the call.
Can you go to web interface-> Feature-> Intercom, disable the "Accept Intercom" and check again?

It's best that you can get a pcap trace so we can check what phone really receive. You can go to Setting-> Configuration, start the Pcap Feature, reproduce the issue, stop it and export.

Please get two pcap trace, one for T38G and the other for T48G.

James, the T48 was on, but I moved to firmware and have the same issue. All the T38's are on

I disabled the Accept Intercom, still same issue.

I am emailing the PCAP's for both phones now.

Thanks again,
Hi Jason,

Thanks for sending the two pcap trace.
From them, I can see that 3cx app send a "Key=OK" action URI to phone which trriger an answer operation in T48G. The specific packet is #234. But a same action URI is not sent to T38G.

I don't know why app send a "Key=OK" action URI to T48G when you click reject. I have sent a mail to 3CX inquiring this. Any update will let you know.


I received a reply from 3cx engineer Aram. I copy it here.

Quote:It is known issue (and can be reproduced on any phone) and there are the restrictions which user should know.
The problem is that he have somewhere 3CX Phone for Windows running in CTI mode and attached to the same extension. It is not allowed.
User can't use the following configurations:
1. Yealink Phone + 3CX phone for Win in CTI mode + 3CX phone for Android - he need to use the one of the 3CX applications, or the 3CX phone for Win should be in SIP mode;
2. "Ring my mobile simultaneously" and "Want to receive more then 1 call" are also not allowed to be used with 3CX phone for Windows in CTI mode;
3. "SIP_FORKED_ID" is also not allowed to be used with 3CX phone for Windows in CTI mode.

So, the customer have 2 choices to fix his problem:
1. Don't use 3CX phone for Win in CTI mode and 3CX phone for Android in the same time;
2. Open 3CX Management Console, go to the Settings->Advanced->Custom Parameters tab, find "SIP_FORKED_ID_BUSY" parameter and change value from 1 to 0.
In this case the PBX rejects incoming call "when one of the sip forked entities sends a busy signal, all invites to all participants are canceled at once".

Thank you for the reply James. I am going to test option 2 now to see if that resolves the issue.

This looks a lot like this:
and this:

I've been trying to get 3CX to check this issue for the last few days.
In short: it's designed that way...
We have reproduced the same problem with T42G phones and have an open ticket with 3CX support who have also reproduced the issue. CTI mode is a big mess it appears for the most part - 3CX should just disable this by default since it has only generated numerous support calls for us. We haven't tried option 2 yet (what else does this break)? Also, there is a way to force Make Call mode by modifying the template but then 3CX says they won't support it. Why doesn't 3CX just say, CTI mode works reliably only if you don't actually use the system? Super frustrating.

One way we've reproduced this issue is by simply calling our own DID (from our mobile phone dialer) with both 3CXphone windows and 3CXphone android running. Desk phone will 'usually' answer immediately in speakerphone (but not always). We do not have call mobile at same time or allow more than one call enabled.
Reference URL's