Yealink Forums

Full Version: NAPTR Defaulting to UDP, How to set TCP
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

As the subject describes, I'm working on setting up NAPTR with SRV records on a Yealink T27P. Everything seems to be working but the phone is defaulting to UDP transport and I need it to use TCP instead. I can't find anywhere to make this change. Is it possible to tell the phone to use TCP for NAPTR and SRV records?
Just following up with my post. From what I understand this is done with the NAPTR record, you set the pirority of the protocol. I've found the following instructions

In this document on page 12 it states:
Quote:The IP phone picks the first record, because its order of 90 is lower than 100. The pref parameter is unimportant as there is no other record with order 90. The flag "s" indicates performing the SRV query next. TCP will be used, targeted to a host determined by an SRV query of "".

I am using Amazon Route 53 and I've setup my NAPTR and SRV records as follows

90 50 "s" "SIP+D2T" ""

0 2 5090
0 1 5090

Does anyone know if I am missing something?
So there seems to be a bug in the *.70 firmware that causes it to only register with UDP. Upgrading the firmware resolves this issue but also causes other issues.
When you using the NAPTR, the transport don't up to phone.
It's up to NAPTR record.You can configure the priority, then the phone will choose TCP transport. The priority up to order parameter, the smaller parameter has higher priority.

There is another possibility, do you fill port as 0?
Please check the attach image.
If the port explicit, the phone use UDP as default transport.
Reference URL's