Yealink Forums

Full Version: Daylight Saving didn't activate on schedule (DHCP vs. Manual Configuration)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
There's an inconsistency in how the phone behaves with regard to Daylight Saving settings.

My original settings have:

Time Zone = "-5 United States-Eastern Time"
Daylight Saving Time = "Automatic"


When I noticed that the phone hadn't changed the displayed time, I tried rebooting the phone (no change) and then tried changing the configuration to explicitly say:

Daylight Saving Time = "Enabled"

The remaining settings that become active are logically correct:

Fixed Type: (x) By Week
Start Month: March
Start Day of Week: Sunday
Start Week of Month: Second In Month
Start Hour of Day: 2
Stop Month: November
Stop Day of Week: Sunday
Stop Week of Month: First In Month
Stop Hour of Day: 2
Offset(minutes): 60


However, these settings are apparently ignored when:

DHCP Time: Enabled

is set. Changing this to "Disabled" caused the phone to display the time correctly.

So, my first question is "what value is the phone expecting to see in the DHCP data in order to be aware that it should be observing Daylight Saving rules?"

My DHCP server configuration (Debian/Linux package "isc-dhcp-server" version 4.1.1-P1-15+squeeze8, the "ISC DHCP server") includes the following settings:

option tz-posix-string "EST5EDT4,M3.2.0/02:00,M11.1.0/02:00";
option tz-name "America/New_York";


as specified in Internet RFC 4833, section 4 "The TZ POSIX String" (http://tools.ietf.org/html/rfc4833).

This contains sufficient information for the phone to be aware of the timezone offset from GMT both during normal time as well as during Daylight Saving (Summer) time.

If the phone is using DHCP-supplied configuration data, and the manually-entered information is going to be IGNORED, it would be helpful if the page would "grey out" those fields that will NOT take effect. Or, at least mention in the "?" pop-up for "DHCP Time" field something like "manually-entered settings below will be overridden by any settings received via DHCP".

This would have saved me considerable time tracking down the cause of the phone failing to "switch to Daylight Saving time".

excerpt from "config.bin":

[ Time ]
TimeZone = -5
TimeZoneName = United States-Eastern Time
TimeServer1 = us.pool.ntp.org
TimeServer2 = us.pool.ntp.org
Interval = 1000
SummerTime = 1
DSTTimeType = 1
TimeZoneInstead = 8
StartTime = 3/2/7/2
EndTime = 11/1/7/2
TimeFormat = 0
DateFormat = 0
OffSetTime = 60
DHCPTime = 1
on IP Video Phone VP530 :
firmware: 23.70.115.13

DHCP time" disabled
Daylight saving time :automatic
primary and secondary ntp server : default settings.
Time zone +1 Amsterdam

After switch to "european summertime" still "wintertime" in the phone display .. until reboot......
Reference URL's