Yealink Forums

Full Version: T46G - How to "lock" the line keys?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I Have looked everywhere but the provisioning documentation has no info on this... Sad

I want to "Lock" the line keys on the screen via the {MAC} provisioning file. That works in the web-interface, but I can't find a working provisioning parameter.

[Image: attachment.php?aid=1170]
Hi tb303,

You'll find the Line Key's description when searched by "linekey" from the Common.cfg File, parameter's format as bellow,
linekey.X.line =1
linekey.X.type =15
linekey.X.value =2 ## 0=Default,1=Float,2=Lock ##

By the way, you can add them to MAC file if you would like to provision via MAC.

I have tried this and it "sort of" works....
I have set this in the MAC config:

linekey.1.type = 15
linekey.1.line = 1
linekey.1.value = 2
linekey.2.type = 15
linekey.2.line = 1
linekey.2.value = 2
linekey.3.type = 15
linekey.3.line = 1
linekey.3.value = 2

And set some DSS keys:

The result is:


As you can see, the 3 lines keys overwrite some of my BLF/Speedial keys when I select page 2.

This looks like unwanted behaviour. Can I fix this, or is this a software related issue?

Kind regards,

I would expect you have to skip those BLF's when programming.
Look at the programming in the phone WebGUI DSS Page.
The LOCKED buttons are LOCKED across all pages automatically. So if you intended to have something there, you need to move it.
The LOCK is doing exactly what it is supposed to.

Note: I see that your WebGUI did not show locked across all pages. That is interesting.
Ok, that's a different way of looking at it Smile

If it really works like that, I guess we will have to work our way around that.

I see in your screen images that the LOCK Did not carry to all pages. Perhaps because you tried to program them as well, they became unlocked.
On mine, 10/11 were blank. I locked 1/2 and now 10/11 and 19/20 are LOCKED.
Reference URL's