Yealink Forums

Full Version: Incoming calls drop after 90 seconds
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm using the W52P, but it is dropping incoming calls after 90 seconds. Outgoing calls do not have the same issue. Every incoming call drops after 90 seconds.

My setup is as follows:

Base station
Firmware Version
Hardware Version

Handset version:

The base station is connected to a Asus RT-N66u router, which is then connected to the Internet. The router is performing NAT.

OpenVPN is enabled on the W52P.

I tried with a different router (Linksys WRT54GL running DD-WRT) and encountered the same issue.

(Note: I have a similar setup with a Snom phone with openvpn and do not face the same issue.)

This is definite caused by the router.

Log in the W52P Base and check the next settings:
Account > Advanced > Account x
UDP Keep-alive Message: Enabled
UDP Keep-alive Interval: 30

Also make sure that in your router SIP ALG is switched off.

Hi Complex1,

Thank your for the advice.

I checked the Keep Alive settings on the W52P and the keep alive was enabled, and the interval was 5 seconds. Actually, I've tested all the keep alive settings options as shown below:

Keep alive type: Default
UDP Keep Alive Interval: 5
Result: Incoming calls drop after 90 seconds.

Keep alive type: Options
UDP Keep Alive Interval: 5
Result: No incoming calls - ie. does not ring.

Keep alive type: Notify
UDP Keep Alive Interval: 5
Result: Incoming call drops after 90 seconds.

So it appears it's not the keep alive setting.

On the router I disabled the SIP Passthrough - it was previously enabled. Unfortunately, this did not resolve the issue. Incoming calls still drop after exactly 90 seconds.

Please be aware that I have enabled OpenVPN on the W52P, so the router will only be seeing openvpn traffic, not SIP traffic. The VPN server is not on my network, but on the Public Internet.

Is it possible, for testing only, to connect the W52P directly to the SIP server without the use of OpenVPN and see if the issue still remain?
Hi Complex1,

Thanks for your reply.

Hi Naveedh,

I replied your in ticket. You can export a level 6 syslog to us.


I am very interested in the outcome.
Please let me know.



I would also like to know the outcome, if possible.

I have had an issue, where incoming calls were being dropped on answer.

My setup consist of Freepbx with w52p Yealink.

When I used a plain old VOIP phone, the call did not drop.
I also replicated the same result with a VOIP app on an iPhone (and the call did not drop)

at the time the base firmware was
handset is

after rolling back to has the issue stopped.

I'm unsure of the reason why, but would like to know why?

I don't find a bug record of this issue. Maybe naveedh didn't send a syslog to us before.
How long the call will be dropped after answering?

For an analysis please get a pcap trace/level 6 syslog/config.bin to us.

Reference URL's