Yealink Forums

Full Version: Trouble Upgrading SIP-T22P Firmware
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am currently on the 7.60.72.1 Firmware, if I try to upgrade to the 7.72.0.80, it will complete the upgrade, but then a few seconds later it was restart and revert back to the 7.60.72.1. Our phone provider say they don't prevent upgrading the firmware.

Anything I could try?
(10-22-2014 11:11 PM)BurtonD Wrote: [ -> ]I am currently on the 7.60.72.1 Firmware, if I try to upgrade to the 7.72.0.80, it will complete the upgrade, but then a few seconds later it was restart and revert back to the 7.60.72.1. Our phone provider say they don't prevent upgrading the firmware.

Anything I could try?

Hi, you might want to try upgrading first to 70 and then to 72, and if that doesn't help then upgrade first to 61 and then go up.
Thanks I will try that. I did just try upgrading it to 7.72 and when the phone came back up I removed the Ethernet. Usually the phone would restart few seconds after coming up but It hasn't yet. So I plugged the Ethernet back in and it seems to be holding. Im going to try to restart and see if it still holds.

Doesn't look like it held. During the reboot, the screen showed "Update Firmware..." and after a bit it it said "Initializing" and then came up back on 7.60. I will try some upgrades further back.

I just tried to upgrade to 7.61 keeping the Ethernet in. It installed the new firmware, then rebooted and went back to 7.60. I'm thinking my voip provider may be keeping the phones on 7.61?
(10-22-2014 11:20 PM)BurtonD Wrote: [ -> ]Thanks I will try that. I did just try upgrading it to 7.72 and when the phone came back up I removed the Ethernet. Usually the phone would restart few seconds after coming up but It hasn't yet. So I plugged the Ethernet back in and it seems to be holding. Im going to try to restart and see if it still holds.

Doesn't look like it held. During the reboot, the screen showed "Update Firmware..." and after a bit it it said "Initializing" and then came up back on 7.60. I will try some upgrades further back.

I just tried to upgrade to 7.61 keeping the Ethernet in. It installed the new firmware, then rebooted and went back to 7.60. I'm thinking my voip provider may be keeping the phones on 7.61?

You must be right about your last suggestion, if the phone was programed thru a provisioning file, then no matter how many times you will change the firmware it will stay with the settings that it comes with the provisioning file.

[by the way I don't understand why your provider didn't change the admin login password, people like you that know how to play around with the phone might cause them some trouble!...]
Hi BurtonD/Abe1048,

Yes, the phone must be reverted by autoprovision.
Please go to setting-> Autoprovision , disable the PNP option, DHCP option, and delete the value in Server URL field.

Regards,
James
Reference URL's