Yealink Forums

Full Version: T46G unable to stop spamers ghost calls
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, using T46G FW 28.72.0.45

I'm receiving constant spamer / ghost calls, right now from extension '105' which don't exists on the PBX.
As noted on other threads, these calls came directly from the internet to my home router IP address, not passing though the PBX.

I tried the suggestions on http://forum.yealink.com/forum/showthread.php?tid=942 that is "Action URI allow IP List" = <PBX public IP address> and "Allow IP Call" = disabled

I also set "Local Anonymous" to "Off" and "Anonnymous Call Rejection" to "On" in the "account -> Basic" tab.

As a last resort, in "Account -> Advanced" I tried to change the "Local SIP Port" to 5071 but it WONT SAVE THE CHANGES!

The only thing I want to know is how to tell the phone to only accept call FROM THE PBX SERVER, and I would like to do this from the web interface, not from a CFG file as stated on http://forum.yealink.com/forum/showthread.php?tid=1692

Sorry for the caps, I'm really frustrated and seconds away to trow the phone out the window.
Hi mdrago,

Sorry for the inconvenience. But please don't worry. Would you please try below steps:
1. Disabled the ip call feature via web interface. Access to web gui->Features->General Information->Allow IP Call, disabled this feature then click confirm to accept the change.
2. If it still have this issue after above step, please enable the sip trust control via auto provision. Sorry for this configuration must be configurated via autop, because there are no correspoding parameter on the web GUI. Kindly you can understand. I will attach you the software , cfg file and video. You just need to refer to the video do it. You can get them from below link:
siptru-autoprovision

Code:
#!version:1.0.0.1
##The x of the parameter "account.x.sip_trust_ctrl " ranges from 1 to max accounts. For example, x ranges from 1 to 6 of T46.
##When you want to enable this sip trust control for account 1, fill 1 to “account.1.sip_trust_ctrl”.
account.x.sip_trust_ctrl=1

thanks
Hi, thanks for your response.
"Allow IP Call" is already disabled (please check my first post), however I'm still receiving spam calls.

I'll watch the video and do it via the CFG if there is no other way... but I don't understand why the calls keep getting through with all the options disabled (Anonymous, IP Call, Action URI, etc.)

I noticed in the call log that the spam calls are "masked" with my own IP, for example, lets say my IP public is "1.1.1.1" the spam call is "105@1.1.1.1"... looks like the spammers are somehow malforming the SIP packets to fake the IP.

Thanks.-
Ok, I watched the video.
It was really easy... I guess I was still thinking on the "via TFTP" days when provisioning a phone was a mayor undertaking.
Thanks again for taking the time to make the video.
(10-16-2014 10:43 AM)mdrago Wrote: [ -> ]Ok, I watched the video.
It was really easy... I guess I was still thinking on the "via TFTP" days when provisioning a phone was a mayor undertaking.
Thanks again for taking the time to make the video.

Hi all,

We have found that using a router with the tomato firmware fixes all theese issues.
Reference URL's