Yealink Forums

Full Version: PC Port will not pass DHCP when connected to Cisco Switch
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a client with a Cisco ESW 520 24-Port switch. It was left at his new location when he moved in about 8 months ago. He plugged everything in and everything worked. So I didn't think there was anything unique programmed in the switch, so I did a hard reset to get access to it. After that, the PC Port on all of our T20 phones stopped working. It appears the phone gets a DHCP address but the PC attached to the PC port cannot get a DHCP address. If I put a static IP on the phone, the PC port doesn't work either.

I have tried everything I can think of. I know Cisco switches can be a little different than others. I have a feeling it may be a VLAN issue, but I don't have any VLANs other than the default VLAN configures.


Thanks in advance!
Hi BeachTech,

What's the firmware of these T20?
Is there a VLAN setting in your switch?
If not, please go to Network-> Advanced, disable phone LLDP feature and disable all vlan setting then check again.
If yes, you can disable phone LLDP feature, manually configure a correct VLAN in WAN port and PC port then check again.

I did all the above, reset the phone to factory defaults, changed the switch from a cisco to a netgear, did the settings again, I cannot make it work. It's important I get a solution to this.
Generally if there is no VLAN configured in the network the Internet port and PC port should be able go get an ip address from DHCP server without any setting.

What's the phone firmware? Can you upgrade to latest firmware and do a reset then check again?
If the device connected to PC port still can't get an ip address please get a pcap trace so we can know why the ip address is not acquired.

I know from experience that Cisco does offer port security for corporate networks that restricts switch ports to offering access to a limited number of mac addresses. The goal being to ensure that employees are not daisy chaining hubs somewhere down the line that may impact overall network performance.

End result is that your switch allows the phone as the single device, but traffic from any other mac address is rejected on that specific port. Try plugging in a plain dumb hub\switch then the phone\computer, and I bet you get the same result - no DHCP\access, as only the hub\switch mac address is allowed.

From Cisco:
"Port Security with IP Phones

Figure 62-1 shows an application in which a device connects to the switch through the data port of an IP phone.

Figure 62-1 Device Connected Through IP Phone

Because the device is not directly connected to the switch, the switch cannot physically detect a loss of port link if the device is disconnected. Later Cisco IP phones send a Cisco Discovery Protocol (CDP) host presence type length value (TLV) to notify the switch of changes in the attached device's port link state. With Cisco IOS Release 12.2(33)SXI and later releases, the switch recognizes the host presence TLV. Upon receiving a host presence TLV notification of a link down on the IP phone's data port, port security removes from the address table all static, sticky, and dynamically learned MAC addresses. The removed addresses are added again only when the addresses are learned dynamically or configured."

Sounds like Cisco phones will automatically work with this port security to allow more devices? I'm not 100% sure, but I bet port security is your issue.

Good Luck
Thanks for your answer and sharing, Bnelson.

Reference URL's