Yealink Forums

Full Version: Different ringtone for internal and external calls
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Our T28P phones used to have different ringtones for internal and external phone calls. I have just upgraded our T28P phones to V2.72.0.75 and now they don't do that any more Sad

The only way that I could find to achieve this magic before, if I recall correctly, was to add everyone to the Local Directory on each phone, and set the ring tone for each phone to Ring2.wav, then assign everyone to a group called Internal and set the ringtone for that group to Ring3.wav

And it's been working like that for a long time. Until I upgraded the firmware yesterday.

Does anyone know why this would no longer work? Or if there is a "better" way to achieve what I want to do?

Thanks, Peter
Hi pjetson,

I am sorry to hear that.
I have tested in my side, and cannot reproduce the issue what you mentioned.
But there is a solution ,and I think it is more convenient for you.
It is a mothod called "Auto Provision".
Now that me introduce how to do in your scene.

1.The syntax in auto provision file for you to set the ring tone for each phone to Ring2.wav.

-->account.X.ringtone.ring_type = Ring2.wav
##It configures a ring tone for account X.

2.Edit a contact.xml to add the group/contact you want . For example: I have added a group--Internal, and set the ringtone to Ring3.wav.
Then ,added some contact to this group.

[Image: attachment.php?aid=994]

3.The syntax in auto provision file for you to upload the contact.xml to all phones.
local_contact.data.url =
For example, enter “http://10.2.1.192:8081/contact.xml”

4.Put both "account.X.ringtone.ring_type = " and "local_contact.data.url = " in a same file
(in my testing ,I renamed the file name to y000000000000.cfg,and note that the syntax "#!version:1.0.0.1" must be added in the front of them).

[Image: attachment.php?aid=995]

Then,I put both auto provison file (cfg file)and contact.xml in the http server:http://10.2.1.192:8081/
[Image: attachment.php?aid=996]

Please pay attention to the "url"
[Image: attachment.php?aid=997]

5.Configure in the phone web interface.
Settings--Auto Provision--Server URL ---Confirm---AutoProvision Now.

[Image: attachment.php?aid=998]

I have put my testing files,Auto Provision guide and http software in the ftp for your reference:Auto Provision

Thx
Reference URL's