Yealink Forums

Full Version: Cant get the handset to Register
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Looking for a little help please. We have a WP52 for a client (brand new) and it was working and the phone registered okay. But, the client moved the base unit and moved it to a different area within their office.

Now the base and phone are not registered and I can't pair them up. Any idea why?

We have tried holding in the base station button and no LED's flash. We have also tried to hold in the base station button and power off and on and wait for all 3 LEDS to come on and the power off again.

Whatever we do the phone will not register to the base

Hi MikeHughes@kube,

1.If the distance is too far or there are many block between the handset and base can cause the single attenuation. Then it will register fails.
Please close the base and then register again.
2.And another probaly reason is the base up to 5 handsets, please check whether you had registered 5 handsets to this base.

If it still can't work and you didn't register 5 handsets to this base , please try base hard reset and try register again. Generally, it will be ok. Please refer to a short video, you can get it from below link:
It seems like the Yealink guy didn't actually read your post before he replied.
I am having the same issue as you, did you ever find a solution?
Sorry eharmon. I just tell the all probabilities cause this issue. If you also have this issue, please refer to my previous post and try base hard reset and try register agin. Smile

thank you
Hi MikeHughes@kube!
You can see my topic "Yealink W52h doesn't regiser", maybe it will help you with your problem.
Reference URL's