Yealink Forums

Full Version: upgrade firmware 2.0.0.9 to what
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi got my hand on some T28P, but have very old firmware

the hardware say 1.0.0.1
and firmware is 2.0.0.9.

so how can i update the firmware and what version can i go to
as i try some of the latest version and it does not update just time out saying talking

so hope some one can say what to do and how to do it
as i would like to try the openvpn bit but i see it not in this old firmware

thanks
CBrunning
Hi cbrunning,

Could you please press the OK key when the phone is idle,then the page goes to status . Then please take a picture for me.
It will be better to know the status of the phone.

Thx
i've attached pic hope you can help

thank
Cbrunning
Hi cbrunning,

Please try to upgrade the phone from 2.0.0.9 to 2.43.0.70,then from 2.43.0.70 to 2.60.0.90 ,finally from 2.60.0.90 to latest version.
You can get the related firmware via below link:
firmware
Thx
ok i've tryed
but it still fails saying phone talking

on one i try in safe mode and it seem to download about 82% then stop and download again then fails, (yes i know it bricked till i get the right firmware on)

so it looks like the 2.0.0.9 can only down load that a bit smaller in size then 2.43.0.70
any older firmware that i can try please

thanks
CBrunning
Hi cbrunning,

I have attahed a V41 firmware in my ftp. And please try to upgrade to 2.41.0.254.
Hope it will help you to solve the question.

V41

Thx
thanks still the same problem (time out in safe mode and talking in web mode)
i have to try again later, start my holiday now

so two week before i can try again

thank
CBrunning
am sorry to say still does not work
am a bit upset that this does not work on both phone i have
look like i have to buy newer version unless you have a very older version of the firmware
Hello cbrunning,

If the phone still doesn't work via the firmware I have provided for you .
Then I am afraid there is no other method ... Sad
So ,maybe you need to buy new phones in your side .
If there is a question ,please feel free to let me know.~

Thx
Reference URL's