Yealink Forums

Full Version: t46g: intercom over speaker rather than headset?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
I have a headset connected to a t46g via an ehs36. When I pick up the phone by clicking the pick up button on my headset, the phone goes into 'headset' mode (the headset light on the t46g turns on) and when I then hang up the phone (again by clicking the button on my headset) the phone remains in headset mode. That means that if someone else wants to intercom this phone, the sound comes through the headset and that is not what I want...I want intercom to always come over the speakerphone. So my question: how can I get an incoming intercom call to always come in over the speakerphone (or stated another way, how can I get the phone to exit headset mode whenever I hang up, or how can I set things up so that non-headset mode is always the default)?

Note that I have the t46g headset priority setting disabled so I don't think that's the problem.
Hi,nice to contact you.
Thanks for your continuously support for Yealink products.
I read your description, unless speakerphone mode(press speakerphone key), I afraid that haven't other way to always choose the speakerphone when connect the headset ,but if you want to both headset and speakerphone can hear voice, you can choose Group Listening feature.
You can configure this feature by seting DSS key parameters:Select the Group Listening from the pull-down list of Type.
Hope can help you.
Thanks. That would be perfect except that group listening does not allow talking through the speakerphone (only through the headset). When another phone intercoms this phone I would like to have people be able to answer using the speakerphone. Any way to do that?
Sorry to bump my own topic, but I keep thinking there must be a way to fix this issue. All I really need is for the default state of the phone NOT to be headset.

To simplify my earlier posts: when I use the headset and then hang up the phone, the phone remains in headset mode (the headset light remains lit when I hang up). If I can get the phone to automatically exit headset mode when I hang it up, I'll be all set. Isn't there some way to do that?

If you connect a headset and use it to answer a call then phone will keep the headset mode on. There is no an option to set this behavior.

If you want to have people be able to answer using the speakerphone you can direcltry press speaker button to switch to speaker channel. From the disscusion before it seems that this can't meet your need? May I know the reason?

(01-05-2015 02:41 PM)Yealink_James Wrote: [ -> ]If you want to have people be able to answer using the speakerphone you can direcltry press speaker button to switch to speaker channel. From the disscusion before it seems that this can't meet your need? May I know the reason?

Hi, James, and thanks for your reply. I need the phone to auto answer intercom calls so if another extension calls via an intercom call the caller will be able to start speaking without the listener having to come to the phone. This doesn't work if the phone is in headset mode (since in that case the phone will autoanswer and the caller's voice will only come over the headphones and thus cannot be heard in the room).

I realize from earlier in this topic that it is possible to set things up in Group Listening mode so that the audio comes over the speaker and headset at the same time, but that doesn't work because I need the person receiving an intercom call to be able to speak without going to the phone.

I have worked around this problem by setting up a W52p in the same room (people can intercom to that one), but that's not ideal (especially since the W52p does not give an option to autoanswer direct ip calls and I would prefer being able to use those for my intercom calls so I can at some point get rid of my pbx and just connect my phones to a voip service and still be able to intercom with autoanswer, as I describe in more detail here: ).
I am setting up T48G's and am running into the same issue. I would strongly encourage an option or SIP header parameter, etc, that would ensure speaker mode for an intercom call. Please advise if there are any solutions.

Related to this, I'm unclear exactly what the T48G is looking for to tell it that an incoming call is "intercom". So far, the only thing that makes it auto-answer is setting the "Answer-After" header. However, at least with that method, the intercom settings "Accept Intercom" and "Warning Tone" seem to be ignored. It auto-answers the intercom call even if Accept Intercom is disabled.

I see through packet captures that for an outgoing call made from an "Intercom" DSS button, that the phone sets the URI parameter intercom=true. However, when that parameter is received on an incoming call it's not appearing to have any effect.

Can you clarify exactly which SIP options/parameters the phone uses for handling an intercom call?
I would like this feature as well. The intercom feature isn't terribly useful if the person can't hear you. Many people here utilize a headset, but we don't have a high call volume. This means that the headset is usually sitting on the desk. If we try to use the intercom, they can't hear it. I would like to be able to set it so that the intercom always goes through the speaker.
Hi All,

I have sent the request to our product dept. They will consider this experience in new firmware.

Please keep us updated, I came from Aastra phones and this seems like such a basic functionality to be missing and badly needed by our users.

Pages: 1 2 3
Reference URL's