Yealink Forums

Full Version: T22P VLAN not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I'm having issues getting my T22P phone to switch VLANs based on the DHCP tag 132.
  • I am using Windows DHCP server
  • I have created two scopes (172.23.70.1 = VLAN 70 and 172.23.19.1 = VLAN 19)
  • I have specified the DHCP tag 132 with a value of "19" (no quotes)
  • I have set the switch port to be default VLAN 70 and tagged for 19
  • I boot the phone, it gets the VLAN 70 DHCP address but doesn't switch VLANs
If I boot the phone and log into the web interface and manually specify the VLAN as 19 then it boots into the correct VLAN and gets a valid DHCP address, so I am sure the tagging on the switch ports is correct and the DHCP scope is working (and DHCP helpers are correct etc.).

I am using firmware 7.71.0.224

Does anyone have any suggestions as to what I can try to resolve this?

Thanks and regards

Andrew.
I'm beginning to think this is a conflict between LLDP and the DHCP tag.

If I disable LLDP on my test rig (Juniper EX4200) then this works, but with LLDP enabled it does not.

Is this the right behaviour? I don't have any LLDP policies configured.
Reference URL's