Yealink Forums

Full Version: W52P Battery Life
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Dear folks / Yealink,

I have recently purchased a Yealink base station and two W52P handsets.
Everything works very well, except that the handsets go from a full charge to only one red bar within an hour of being off the cradle.
They will still last for a while like that, but it seems that neither will hold a charge well; much less than what is advertised anyway.

The base station is running firmware version adn the handsets
I tried obtaining as recommended here, but it's no longer available.

Any help would be appreciated!
Please upgrade firmware to V73 and try again.

handset firmware:
base firmware:

Any updates, please let me know.
Thanks for your reply.

I have tried the upgrade, but now when logging in to the web interface it says "Handset firmware upgrading. Please wait" even 24 hrs later.

I am not on site; is there any way to reset the base remotely?
Hi namezero111111,

Please try below steps:
1.You can clear the cache of the broswer and reflash that web GUI and try again.
2.If it still doesn't work and you can access to web GUI->phone->upgrade tab, please press the Reset now in the Reset to Factory.
3.After above steps still can't work and you are on site, please try hard reset. Please refer to this video. >>DECT_Reset<<

Reference URL's