Yealink Forums

Full Version: [Bug] Direct IP call works with certain menu sequence not others
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I am saving direct IP call addresses into the Local Contacts directory with the syntax sip:telnum@[ipv6address]. What is buggy is that this works great in one context and not others.

The following sequence works reliably:
Spkr -> Dir -> Local Directory -> All Contacts -> Contact select
A serverless direct SIP IP call is initiated, rings and connects.

However, using this sequence:
Menu -> Dir -> Local Directory -> All Contacts -> Contact select
The LCD displays as if calling, but there is no ring tone and the call doesn't go through and eventually times out. The other party hears nothing either.

I have also put SIP addresses into an XML file and tried selecting them there. "Detail" shows the correct SIP address, yet it fails identically to the above approach.

Conclusion: It looks like the SIP direct calling feature isn't fully integrated into the phone. Sad

Firmware Version
Hardware Version
Hi randomandy,

Could you please upgrade your firmware to the latest version firstly?
And try again to confirm this issue whether have fixed in the latest version or not.
You can get the firmware from here.>><<

Any updates, please feedback to me.
Right - sorry for not trying that first. (The bug wasn't listed in the release notes so I hadn't bothered.)

Anyway, I've upgraded to and the behavior remains the same as described in original post. Sad
Hi randomandy,

Do you mean want to add a contact and make ip call?
If yes, Why don't you add a contact like below:

Office Number: ip address(like

Then you can dial a ip call via directory.

If your scenario is not as mine, please describe more detailed operations about it.
BTW, do you register your account in your phone?

thanks in advance
Yes, I was trying to dial by IP using a contact, though I was using the syntax sip:telnum@[ipv6address].
Using an IPv4 address as you advised, the office number can be of the syntax and then it works correctly from the directories.
But then what is the syntax to dial an IPv6 address?
I tried 2001:dead:beef::1 and [2001:dead:beef::1] and neither work unless I use a different menu path as described in my first post.
Hi randomandy,

Thanks for your feedback. Because we don't use ipv6 address inside.
So I can't reproduce your scenario in my side.
It is kindly that if you can make a short video about the entire operations for us.
Then we can understand the scenario much better.
And could you provide more info about it?
1. Why do you use ipv6 address to ip call? Not ipv4 address?
2. How many phones you have and need this feature?

Sorry for the inconvenience.
Quote:Because we don't use ipv6 address inside. So I can't reproduce your scenario in my side.

Wow. I don't know how you expect to develop a feature (IPv6) you can't test. Undecided

Here is a video of the bug. Can you view it?
Has anybody reviewed this bug? Are there any plans to fix it?
In order to do more troubleshootings, please configurate your IPV6 contact in the directory then we test it in my side and supply syslog level 6, config.bin and pcap and send to me.
How to Get the Correct Syslog, Config.bin and Trace
Could you observe the behavior in the pcap files I emailed you?
Pages: 1 2
Reference URL's