Yealink Forums

Full Version: Disable Call Rejection
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have several T46G's deployed, and I'm getting some reports that phones are not ringing for some users... but I have a feeling that some users are hitting the reject button to avoid answering calls. Then they go "oh my phone didn't ring, I don't know why". This is reinforced by SIP "busy" messages coming back 4-5 seconds after the phone is being rung.

I'd like to disable the ability for people to reject calls. Is there a way to do this?
I recommend you take a look at Softkey Layout Template in the Administrators Guide. You can modify softkeys based on the current call state. Didn't tried this myself yet, but seems to me what you are looking for.
Thanks that worked great.. I will post what I did, in case anyone else needs to do this.

The autoprovisioning zip file had a template already made, so I just edited that. In the MAC configuration file, I added these lines:

Code:
phone_setting.custom_softkey_enable = 1
custom_softkey_call_in.url = tftp://192.168.1.245/callin.xml

and in the callin.xml file, I had this:
Code:
<CallIn>
  <Disable>
    <Key Type="Empty"/>
    <Key Type="Switch"/>
    <Key Type="Reject"/>
  </Disable>
  <Enable>
    <Key Type="Answer"/>
    <Key Type="Forward"/>
    <Key Type="Silence"/>
  </Enable>
  <Default>
    <Key Type="Answer"/>
    <Key Type="Forward"/>
    <Key Type="Silence"/>
  </Default>
</CallIn>
Hi nicknomo,

You can directly modify the softkey on Incoming call status. Please refer to below picture.

[Image: attachment.php?aid=808]
Thanks support... Not sure how I missed it in there.
You are welcome.
Sincerely thanks for your support to Yealink product!
Reference URL's