Yealink Forums

Full Version: Handsets not ringing for incoming calls
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
I have 4 handsets registered to the base and they are all set to use Line 1 (incoming and outgoing). About 70% of the time at least one of the handsets (sometimes more) won't ring for an incoming call.

If I pick that handset up right after it misses the call, sometimes it will show "Searching for Base", other times it won't show any error until I try to do something like going to Info --> Base, or making an outgoing call. Then it shows "Synchronizing, please wait".

The base is running (forced to this firmware by Vonage Business auto-provision); handsets I have tried on and with no difference. Tried factory resetting base and auto-provisioning; also no difference.

Handsets are all located in the same room for testing; base is sitting on top of a desk.

Any ideas?
Hi belias,

could you upgrade the base and the handsets firmware to the latest version. Then reset the base and test again.
The latest firmware version of base station is

The latest firmware version of handset is

As I mentioned in the original post: "The base is running (forced to this firmware by Vonage Business auto-provision); handsets I have tried on and with no difference."

If you have a suggestion on how to force the base to use, I would be happy to try. But if Auto Provisioning is turned on, it immediately reverts back to

Thank you

- Brian
Hi belias,

Sorry for the inconvenience.

1.Please go into webpage->Settings ->Auto provision, then delete the content of Server URL field. Then it won't be Auto provision.
2.Upgrade the base firmware to or

3.reset the base and try again.

We have similar problem. We have seen it twice now.

W52P new March 2014
Base: f/w h/w May 2014
Handset: f/w (Tried OTA and USB firmware upgrade but it would not work.)

The handset loses inbound ringing. I can make outbound calls, no problem. I can properly hear the person on the other end. But when they call me… no ring.

Via web interface, on home screen/status page, “start paging” – the handset does NOT ring.

How I fix it: Export settings. RESET to factory and then import settings. Then, inbound ringing works.

How it is connected: A hardware router with VPN to our office. The Yealink settings are really simple – just SIP parameters, change IP and DNS to a valid server, and the phone registers and makes/receives calls.
Hello and thank you for the quick reply.

I have followed the suggestion to delete the "Provisioning Server" URL (it is now blank), but no matter what I do the FW upgrade to will not apply successfully. It appears to load and apply as normal, but as soon as the base resets it reports that it is still on (I did confirm that the Provisioning Server" was still blank).

Note: If I factory reset the base, I can then upgrade the FW to, however I don't believe the base will connect to the VoIP provider without at least an initial auto-provision.

I'm happy to send logs if that would be helpful.

Hi belias,

Thanks for your reply. Sorry for the inconvenience.
You can directly upgrade the firmware via web user interface without reset the base firstly. After resetting, you should register your account again.

Could you provide more information about it for us?
1. If you have 3 handsets register to the base, Is there the same issue? What if 2 handsets?
2. Why do you register 1 account in the 4 handset at the same time?
3. How often does the situation what "Searching for Base" or "Synchronizing, please wait" occur?

Please try follow steps:
1. If you have other account, please try register another account and try again. Is there the same issue?
2. In order to do more troubleshootings, please supply syslog level 6, config.bin and pcap for us.

How to Get the Correct Syslog, Config.bin and Trace


Sorry, perhaps I wasn't clear in my earlier post. When I directly upgrade the firmware, it WILL NOT LOAD unless I do a factory reset first. Then, after I load the auto-provisioning server address, the firmware goes back to

To answer your questions:

1. 3 handsets works PERFECTLY. I have tested this 100+ times and there are no missed incoming calls; all features works as expected.
2. I am actually not registering 1 account in all 4 handsets. I have 4 separate SIP accounts; each handset is registered to one SIP account. The VoIP provider has a "call group" that rings all 4 accounts at the same time. [[Note: For testing purposes, I have tried configuring 1 SIP account registered to all 4 handsets and this produces exactly the same issue.]]
3. When all 4 handsets are registered, about 80% of the time one (or more) handsets "misses" an incoming call then shows "Searching for Base" or "Synchronizing, please wait".


1. Yes - it is not account dependent. It is number of handsets dependent.
2. I will work on this tomorrow. However, I'm not sure I can test with the latest base firmware (see above).

Thank you.
EMail sent to Yealink support containing the files as requested. This issue occurs routinely whenever 4 handsets are associated with the base..easy to reproduce.


- Brian
Can you tell me your email address? Or send your email again to

Pages: 1 2 3
Reference URL's