Yealink Forums

Full Version: W52 ovpn drops after initial connection
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi

We have a number of W52's connected to pfsense's ovpn server.

A couple of days ago, 2 of our deployments stopped working. 1 site has 4 x W52's and 1 x T26p, only the T26p now can connect. The other site has 1 x W52 and this cannot connect. Other deployments of W52's using similar vpn.cnf connect fine. FYI, vpn cnf follows:

dev tun
persist-tun
persist-key
cipher BF-CBC
tls-client
client
resolv-retry infinite
remote [OUR VPN SERVER IP HERE] 1198 udp
tls-remote VOIPserverCERT
ca /config/openvpn/keys/ca.crt
cert /config/openvpn/keys/client1.crt
key /config/openvpn/keys/client1.key
ns-cert-type server
passtos

Nothing has changed on pfsense.

pfsense is logging "TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)"

Can anybody help with this?

Thanks
Hi dpl73,

Please check your network connectivity firstly.
Do you mean that your W52P can connect to presense server sucessfully before?
Do you reboot the base and test again?
We have about 20 of these deployed in various locations. All are fine, except for one site who have 4 x w52 and 1 x t26. The w52's connect (vpn) and register for about 2-3 minutes and then the vpn drops. Normal network connectivity is maintained on other devices PC's, Servers, etc.. and the T26p maintains it's VPN connection, so it is not likely that the internet connection is dropping.

I've tried base resets, various firmware down/up-grades, new vpn.cnf's and certificates.

This site worked fine for about a month, and then there was an network issue with the Telco/ISP which has been resolved. After the WAN connection was back up, this started happening.
Hi dpl73,

The W52P can connect to the Openvpn server?
Our customer have met the same issue. The reason is network.
So could you check your network parameter fistly and test again´╝č

If it also can't work, please supply the tar file and send it to us. We will test it locally.

thanks
Reference URL's