Yealink Forums

Full Version: headset echo
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
we are running t26's with firmware 6.72.0.25. all phones use Plantronics cs540 headsets with the EHS36. the ehs was upgraded to the 3.x firmware.

all phones have echo cancelation turned on (settings->voice)
jitter buffer set to adaptive,min delay = 0, max delay= 300, normal = 120

the person using the headset hears the echo of themselves when they talk. it does not happen on the handset or speaker phone.

we have 15 phones setup with this configuration and everyone complains about the echo.

are the above settings correct? and are there any suggestions on how to get rid of the echo?
(05-29-2014 09:05 AM)bksales Wrote: [ -> ]we are running t26's with firmware 6.72.0.25. all phones use Plantronics cs540 headsets with the EHS36. the ehs was upgraded to the 3.x firmware.

all phones have echo cancelation turned on (settings->voice)
jitter buffer set to adaptive,min delay = 0, max delay= 300, normal = 120

the person using the headset hears the echo of themselves when they talk. it does not happen on the handset or speaker phone.

we have 15 phones setup with this configuration and everyone complains about the echo.

are the above settings correct? and are there any suggestions on how to get rid of the echo?

Just a stab in the dark here... Sometimes echo cancellation routines have trouble with adaptive jitter buffers in VoIP devices. Give a fixed jitter buffer a try and see if that does anything. It probably won't, considering this is a headset only issue, but its worth a shot. It does sound more likely that the phone's echo canceller simply isn't being enabled when the headset is activated... but that is also just a guess.
(05-29-2014 10:24 AM)nicknomo Wrote: [ -> ]
(05-29-2014 09:05 AM)bksales Wrote: [ -> ]we are running t26's with firmware 6.72.0.25. all phones use Plantronics cs540 headsets with the EHS36. the ehs was upgraded to the 3.x firmware.

all phones have echo cancelation turned on (settings->voice)
jitter buffer set to adaptive,min delay = 0, max delay= 300, normal = 120

the person using the headset hears the echo of themselves when they talk. it does not happen on the handset or speaker phone.

we have 15 phones setup with this configuration and everyone complains about the echo.

are the above settings correct? and are there any suggestions on how to get rid of the echo?

Just a stab in the dark here... Sometimes echo cancellation routines have trouble with adaptive jitter buffers in VoIP devices. Give a fixed jitter buffer a try and see if that does anything. It probably won't, considering this is a headset only issue, but its worth a shot. It does sound more likely that the phone's echo canceller simply isn't being enabled when the headset is activated... but that is also just a guess.

thanks. the only jitter buffer that is enabled is in the phone itself. nothing in the session border controller or the pbx. I will try changing the jitter buffer from adaptive to fixed in the phone and see if that helps. hopefully someone from yealink will look at their firmware and confirm that the echo cancelation is in fact active when the headset is active. it would be a reall pisser if it was not because it means I will probably have to replace the phones with another brand
(05-29-2014 11:45 AM)bksales Wrote: [ -> ]
(05-29-2014 10:24 AM)nicknomo Wrote: [ -> ]
(05-29-2014 09:05 AM)bksales Wrote: [ -> ]we are running t26's with firmware 6.72.0.25. all phones use Plantronics cs540 headsets with the EHS36. the ehs was upgraded to the 3.x firmware.

all phones have echo cancelation turned on (settings->voice)
jitter buffer set to adaptive,min delay = 0, max delay= 300, normal = 120

the person using the headset hears the echo of themselves when they talk. it does not happen on the handset or speaker phone.

we have 15 phones setup with this configuration and everyone complains about the echo.

are the above settings correct? and are there any suggestions on how to get rid of the echo?

Just a stab in the dark here... Sometimes echo cancellation routines have trouble with adaptive jitter buffers in VoIP devices. Give a fixed jitter buffer a try and see if that does anything. It probably won't, considering this is a headset only issue, but its worth a shot. It does sound more likely that the phone's echo canceller simply isn't being enabled when the headset is activated... but that is also just a guess.

thanks. the only jitter buffer that is enabled is in the phone itself. nothing in the session border controller or the pbx. I will try changing the jitter buffer from adaptive to fixed in the phone and see if that helps. hopefully someone from yealink will look at their firmware and confirm that the echo cancelation is in fact active when the headset is active. it would be a reall pisser if it was not because it means I will probably have to replace the phones with another brand

Yeah, like I said, a stab in the dark. Sorry I can't be of more help. Yealink will probably ask you to set the syslog to the highest setting, to do a packet capture, and export both...

From what I remember, the syslog shows some of the audio stuff, and that includes entries about the "aec". I believe that stands for acoustic echo canceller. They will probably need to see that in order to tell what is going on in your phone.
Do you connect Plantronics cs540 with EHS36 correctly?
In order to do more troubleshootings, please supply syslog level 6, config.bin and pcap and send to support@yealink.com or support.usa@yealink.com.
How to Get the Correct Syslog, Config.bin and Trace
can I turn on the syslog and trace and leave them on without impacting the phone. the issue does not occur on every call so what I want to do is turn on the syslog and trace, leave them on, and then when the problem occurs to immediately go into the phone and grab the data. so will turning on syslog and trace impact the phones voice performance?
(06-03-2014 12:32 AM)bksales Wrote: [ -> ]can I turn on the syslog and trace and leave them on without impacting the phone. the issue does not occur on every call so what I want to do is turn on the syslog and trace, leave them on, and then when the problem occurs to immediately go into the phone and grab the data. so will turning on syslog and trace impact the phones voice performance?

The syslog is always running anyway. Setting the syslog to 6 just increases the number of details. Once the syslog gets too long, I believe older entries are cycled out.

For the packet capture, I believe it only holds the last 15 seconds of audio or so... although I'm not sure how this changes from phone to phone, or if leaving it running a long time will cause other issues.
Hi nicknomo,

You can use wireshark to capture the trace for a long time.

1. connect your computer to your phone's PC port
2. go to webpage->Network->Advanced->Span to PC, enable span to PC Port.
3. run the wireshark in your computer
Wireshark tool and instruction
Reference URL's