Yealink Forums

Full Version: problem with microphone in the phone sip-t22p
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello . I have about 20 phones sip- T22 , 6 months everything worked perfectly . the problem started with one phone . when picking up the phone for a call that a friend could hear perfectly, but my voice was not heard or had heard noises and creaks . When I talk handsfree no problem. I changed this phone , connect and configure a new phone , I installed the latest firmware on the phone and the problem reappeared . the device has three lines, each line set to different operators , the problem remains on every line . I tried to install different firmware , but it does not help. computer connected to the phone , it can be a problem ? I tried to disconnect the computer from the phone , did not help . I think that the phone will burn something , but can not figure out from what?
I do not want to burn another phone . please tell me what to do ?
Do you upgrade to the latest firmware, then the issue appear?
Do you use a different Codec?
Can you contact with your distributor for help? And check the SN numbers with them.
Yes, I have tried different firmware, and older.
Yes, I used different codecs PCMU, PCMA, G729, G722
I contacted with my seller (ISOFT)
He changed me to a new phone, but after the firmware and settings, the situation repeated
Hardware Version
MAC Address 00156528411c
SN 1102211090400467
Please supply your pcap, config.bin and syslog level 6 to your distributor for help or
How to Get the Correct Syslog, Config.bin and Trace

I recently got a T22P and have the same problem.
I made a factory reset, flashed it to V73, made a factory reset again and configured it - the mic is not working, not in phone, not in handset.

Has there been a solution meanwhile?

Reference URL's