Yealink Forums

Full Version: personalized configuration settings protection not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Just tried on a bunch of T42G and T46G to setup the personalized settings protection but it's not working.

I added : "
auto_provision.custom.protect = 1
auto_provision.custom.sync= 1
to the provisioning file.

When the phones are booting they are trying to read the mac-local.cfg on the TFTP server and retry a few times but after that they never write the local settings to the TFTP.
I tried creating an empty dummy file but it doesn't help, it only prevent the retries

By pure luck it seemed to work on one of the phone while i did some tests but it stopped working after that without any reason.

I tested it with the firmware on the T46Gs.

Any clue ?

Thanks in advance.

I test here, any thing work normally.

Normally, the phone won't upload the file immediately after any configuration change.
Suggest that you can wait more time to test.

Any update, please let me know. Meantime, please tell me the auto provision URL.
I may be wrong, but in our experience it doesn't update the MAC-local.cfg file to the server until after about 5min after the phone boots.
Well it has been running for days and the TFTP log doesn't show any write request...
the autoprovision url is tftp:// It's a TFTP server on a local linux.
I tried upgrading to the latest firmware ( but still the same.
Reference URL's