Yealink Forums

Full Version: T29G - Alert info autoanswer fails
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

We are sending INVITES with the header "Alert-Info: ; answer-after=0" to a T29G, the 90% of calls are autoanswered correctly, but there is a 10% of them that stills in Ringing state until the user answers the call manually.
Could be a bug? I saw in the phone debug that INVITE header is the same in both calls but in one of them the Intercom is activated and in the other one not.
Attached you can find a sample phone debug file of each kind of call.


I will let our R&D to check then tell you update.
Thank you, I look forward to hearing from you.

From the file, we find when the incoming call with "Alert-Info: ; answer-after=0", the phone has exit calls. Right?
When there are exit calls, the new incoming call with "Alert-Info: ; answer-after=0" can't be auto answer.

If you want the phone can auto answer the incoming call when there is an exit call, please go to web interface->Features->Intercom->Intercom Barge, then enable this feature.

Please test then let me know the result.
Hello Karl,

I don't know what do you mean when you talk about "exit calls". Are you saying that the user is in a call? Or the phone is receiving more than one call? Can you explain me the difference between the two files more in detail?

Thanks in advance,

I read the Intercom Barge help, and it is useful when you are in a call and another incoming call comes.
But this is not the case I sent you, the user was not in a call when he received the inbound call that we want to be autoanswered.
Where have you seen that the phone is on call when it receives the autoanswer call?

We check the file you sent to us.
In the fail syslog, you can see that when the server send invite to phone.
The phone will respond 486 busy here, so we double there is an exit call.
Can you check again?
Reference URL's