Yealink Forums

Full Version: Echoes with T32G phones
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Since installing our new phone switch and yealink phones in January we have been having intermittent echo issues. I would place a call to someone inside the building. They would answer me on speaker. They would report hearing a very annoying echo. When they go off speaker, the echo goes away and when they go back on speaker the echo does not return. The next call can be free of echoes. We have also had a report of outside and inside callers using one of our conference lines but the echoes were so bad, we had to end the conference call and use an alternative conference call solution. I first contacted Barracuda Networks. They had me remove all but their G.711 codecs from the phone switch configuration. Echoes persist and they are stumped. Echo cancellation is enabled in all phones. Do you have any idea what we can do?

Yealink T32G FW:
Cudatel Communications Server 470 FW:
Do you test other phones?
Do you feedback to your distributor?
In order to do more troubleshootings, please supply your distributor syslog level 6, config.bin and pcap.
How to Get the Correct Syslog, Config.bin and Trace
We have this EXACT same issue with about 90+ Yealinks T22 & T32. Were you able to ever get this resolved? The T32 firmware we use is:
We have off and on seen similar issues on installs we do.
What we started doing was turning down the GAIN input of the MIC on the handset and turning the side tone all the way down and this cleared up our issues.

What PBX are you running?
You cannot configure these settings in the web interface they are in the provisioning files only.

Here are the two values we set.

voice.handset_send = 1
voice.side_tone = -48
We use Cudatel and another platform based on FreeSWITCH softswitch.

It appears the issue only happens when someone is talking on speakerphone, even if the volume on the speakerphone is very low. So now, I wonder if it is a codec issue and if G.711 should be used as the primary codec versus G.722
We are getting the same with T22 Phones. We run 3CX and had no issues then over night, normally during a call we get an echo. It is so off putting we have had to end some calls. Yealkink any ideas? I have tried the latest version of the firmware and it makes no difference. It is not every call and normally happens during.

Below is our 3CX Yealink Procisioning Template.
#Enable or disable the voice activity detection feature; 0-Disbaled (default), 1-Enabled;
voice.vad = 0

#Enable or disable the comfortable noise generator; 0-Disabled, 1-Enabled (default);
voice.cng = 1

#Enable or disable the echo canceller; 0-Disabled, 1-Enabled (default);
voice.echo_cancellation = 1

#Configure the volume of the side tone. It ranges from -48 to 0, the default value is -3.
voice.side_tone= -3

#Configure the sending volume of Speaker, Handset and Headset. It ranges from 1 to 53, the default values are 25, 35, 30.
#Require reboot;
voice.handfree_send = 25
voice.handset_send = 35
voice.headset_send = 30

#Configure the type of jitter buffer; 0-Fixed, 1-Adaptive (default);
voice.jib.adaptive = 1

#Configure the minimum delay, maximum delay and normal delay. The default values are 0, 300, 120.
voice.jib.min = 0
voice.jib.max = 300
voice.jib.normal = 120

#Define the voice tone, the valid values can be Custom (default) or voice tone of different countries. For example, United States, France, Germany and so on. = Custom =

#Configure the receiving volume of Speaker, Handset and Headset. It ranges from 0 to 15, the default value is 8.
voice.handfree.spk_vol =
voice.handset.spk_vol =
voice.headset.spk_vol =

#Configure the dial tone volume of Speaker, Handset and Headset. It ranges from 0 to 15, the default value is 8.
voice.handfree.tone_vol =
voice.handset.tone_vol =
voice.headset.tone_vol =

#configure the preview call mode; 1-Ignore:the mixed of tone and RTP (default), 2-Force: discard the RTP and play the tone, 3-Skip: skip the tone to play the RTP;
Hi Jason,

Generally Echo problem is caused by environment or PBX server. You can have the two test:

1.When you hear the echo, mute the other side and check whether there is still an echo.(generally echo is transmitted back by the other side).
2.Have a try of IP call and check whether there is a echo.

Hate to bring our bad experience. Last year, we tried many things to shake out our speakerphone echo issues with a handful of T32G phones during initial reliability testing of Yealink phones with some of our beta customers. Unfortunately, we found the speakerphones on T32G phones on the latest firmware to not be reliable. Specifically, while using G.722 HD codecs the Yealink would give off echo to the remote party. It would not be every call, but if you are a regular speakerphone user you would run into the issue typically about once every 1-2 days. It happened under G.711u as well but not as bad/noticeable. Under G.722 once an in-progress call had an echo back issue it could not be resolved unless the person on the T32G picked the call off speakerphone to handset, the T32G was placed on mute, or the T32G called back (terminate/reinitiated the call). Further more, the person on the T32G wouldn't be aware they were creating echo for the remote party unless they were told of it. This became quite problematic on dial-in conference calls.
Eventually, we degraded the codec support to G711u, and we still had some (albeit less) complaints. Next we pulled T32G phones from our support list and redeployed a different phone hardware vendor to all customers (vendor that I would not name on this forum). These bad experiences were pure direct SIP/RTP conversations, both T32G<->T32G as well to other vendor SIP devices, as well off-network terminations. Remote party didn't matter for us. From our observations, it appeared the T32G speakerphone had a code bug whereas it dynamically (randomly) switched off the echo-back echo cancellation on the speakerphone for a call and couldn't switch it back on until terminating the call. We did not have enough data points to say if this affected any other Yealink phones. We tried the 2 most recent firmware revs (which made no difference). Some data we collected seemed to indicate phone positioning altered the amount of echo back, but it didn't resolve the fact that it was occurring in the first place.

Sorry as we did not find a good solution.
We configured our Cudatel to use only G.711 alaw and G.711 ulaw codecs for incoming and outgoing per Cudatel advice. This seems to have done the trick for us as I have not heard an echo for some time now nor have the users I have asked.
For us, turning off G.722 HD support wasn't a long-term option. Since the speakerphone works fine for the majority of calls, I really wish Yealink would acknowledge, find, and resolve this intermittent bug.

***Yealink support, do you have an (open) acknowledged firmware issue on this problem with the speakerphones?
Pages: 1 2
Reference URL's