Yealink Forums

Full Version: Ring timeout
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have two types of yealink phones in our organisation T22 and T38G.
For both, even if in the PBX I set a ring timeout of 5 minutes, the phone send a busy after only 2 minutes.
Where can I find the setting to let the phone ring forever and let the SIP PBX decide when to cancel a ringing call.

Do you enable "No Answer Forward" for 120 seconds?
I don't know if you got a solution, but I'm facing the same problem with T46G phones. Phones stop ringing after 120s, whatever the configuration. The "No answer Forward" option is disabled.
Is there any way to keep the phone ringing without receiving a "SIP response 486 Busy Here" after this time ? I've tried with 28.71, 28.72 and beta 28.73 firmware families, without any success.
Hi Nevox,

1. Please upgrade the firmware to V73 BETA version firstly. You can get the firmware from this announcement.
V73 Beta2 Version Firmware And Release Notes of Version 73 Release

2. It configures the duration time (in seconds) in the ringback state via auto provision. The auto provision sentences are:
##It configures the duration time (in seconds) in the ringback state. If it is set to 180, the phone will cancel the dialing or reject the incoming call ## if the call is not ##answered within180s. The default value is 180. SIP-T48G/T46G: X ranges from 1 to 16.

For more information, please refer the V73 autop guide ,template and you can get them from this announcement which is "V73 Beta2 Version Firmware And Release Notes of Version 73 Release " also.

Thank you for your reply. I tried this setting, but without any success... Here is my MAC.cfg file:

account.1.enable = 1
account.1.label = 100
account.1.display_name = 100
account.1.auth_name = 100
account.1.user_name = 100
account.1.password = mysecret
account.1.outbound_proxy_enable = 0
account.1.sip_server.1.address =
account.1.sip_server.1.port = 5060
account.1.sip_server.1.expires = 3600
account.1.ringback_duration_time = 3600
account.1.subscribe_mwi = 1
account.1.dialoginfo_callpickup = 1
account.1.direct_pickup_code = **
account.1.always_fwd.enable = 0
account.1.busy_fwd.enable = 0
account.1.timeout_fwd.enable = 0
account.1.timeout_fwd.timeout = 2000

The calls are still rejected after 120s (that's also the value appearing in timeout FWD on the GUI).
Am I missing something? Or is it a bug?

Hi Alban,

I have tested and submitted it to our R&D. We will fix it in the V73 official version in the middle of November. Thank you for your feedback. Smile
I have an open 3000 and my provider is Engin. My problem is that when the phone rings it times out after the 5th ring, which usually doesn't give me time to answer the phone. Could someone tell me which parameters have to be reconfigured to change the amount of time allowed before the call rings out.

Please i will want you to help me clearify my enquiry about how i want to use yealink ip phone to carryout a project.

I will like to create a “call to listen music“ kind of service using Yealink IP phone. I will want unlimited callers to call the phone at the same time enabling all numbers dialing the phone to ring up to 24 hours enabling them to listen to music jamz set as ringback tone for free without the callers being charged by their network operator. Please make your comment on the following questions below.

Can Yealink phones accept unlimited calls dialed at the same time?

Does Yealink phones enable custom ringback tone?

Can one stream live audio to Yealink phones so as to use it as ringback tone?

stream live audio to Yealink phones so as to use it as ringback tone?

Can Yealink phone set to ring 24 hours and end the call once the 24 hours of ringing elapse?

Does Yealink require internet connection to enable it work?

I look forward to hear from you.


Morris Joseph
Reference URL's