Yealink Forums

Full Version: backward rear ports PC / Internet
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a T-26P phone and have discovered that the phone will only get an IP address if the network cable is connected to the PC port on the back of the phone.

If this is normal, how do I get PoE to work on the PC port?

This is not normal. Just 1 phone? Many phones?
(03-23-2014 12:33 PM)craigreilly Wrote: [ -> ]This is not normal. Just 1 phone? Many phones?

It is every phone, we ordered 12 T26P phones. Also we had a couple T22P phones that act the same way.

Both ports have to be plugged in. So the internet port into the PC and PC port into the wall jack (where dhcp lives).

Otherwise the phone just keeps saying "obtaining IP address".

Also the first time the phones boot up it says, "network checking" then takes you to the WAN configuration page, then I click back and it reboots the phone and gets an IP (but only if the PC port is plugged into the wall).

I can get the ports to work temporarily by:

1. disconnecting the network cables while phone is running
2. perform factory reset from phone
3. wait for "network checking..." and subsequent error because no network cable is present
4. press the back button and wait for phone to reboot
5. plug in the network cables the correct way (wall jack to Internet / PC to PC port)

But if I reboot it, it fails to get an IP address again.
Hi rilliam´╝î

Internet Port should be connected to wall jack and PC Port should be connected to PC.
What is the version of your phone?
They should be but they only work correctly if the ports are swapped.

T26P - Firmware / Hardware
T22P - Firmware / Hardware
T22P - Firmware / Hardware

Serial numbers:
Also do you check to use other POE cable?
Do you test factory reset to all of them ?
Do you try to upgrade firmware again to exclude the deficient firmware upgrading?
I finally figured this out. The problem was that the INTERNET port tags packets for VLAN 1 even if VLAN is DISABLED. Our switches are configured in such a way that VLAN1 is not permitted. This is why I was not getting a DHCP reply.

I did find yealink documentation somewhere that instructs the user to swap the INTERNET and PC ports as a troubleshooting measure. This does work to get the phone online but thats where the fun stops.
I think we enable LLDP to send the VLAN tag to all ports by default. So you can disable LLDP and try again.
Reference URL's