Yealink Forums

Full Version: No results using LDAP
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I followed the guide from and get no results using LDAP on all of my Yealink T32Gs.

Does the following look correct?

LDAP Name Filter            (|(cn=%)(sn=%))
LDAP Number Filter        (|(telephoneNumber=%)(Mobile=%)(ipPhone=%))
Server Address            (domain.local)
Port                    389
Base                    dc=domain, dc=local
User Name                cn=John D,dc=domain,dc=local
Password                (John D's domain password)
Max. Hits(1~32000)        50
LDAP Name Attributes        cn sn
LDAP Number Attributes        Mobile telephoneNumber ipPhone
LDAP Display Name        %cn
Protocol                Version3
Search Delay(0~2000)ms    2000
Match Incoming Calls        Enabled
LDAP Sorting Results        Enabled
LDAP Lookup For Pre-dial/Dial     Enabled
is domain.local what you have entered or just that way for forum?
username - I would do domain\johnD or what ever the login is.
Changed the username to use that login and it worked (perhaps the Yealink guide could be updated to include this)! However, it is pulling up every single user, including disabled ones. How can I refine the results displayed to not include these?
I keep DISABLED USERS in another OU in AD... so they do not come up.
Disabled Users were in another OU.

If I want to refine the results, can I not add the OU I want to the Base? For example,
dc=domain, dc=local, ou=officename
Put the OU at the front usually...
I missed initially that you had no OU. Sorry...
I think you should refer to different guide about T3X.
Using LDAP Phonebook on Yealink SIP T3XG Phones Rev_70.0
(03-13-2014 12:05 PM)craigreilly Wrote: [ -> ]Put the OU at the front usually...
I missed initially that you had no OU. Sorry...

No problem.

I get results when I put just one OU but when I add a second OU there are no results. Is there some way I have to do it differently to include both OUs?
Reference URL's