Yealink Forums

Full Version: T46G Won't Register behind Linksys Router
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I just purchased a T46g, but it will not register when it is connected behind my linksys WRT54g router.

When I connect the phone directly to my cable modem it registers fine, but when I connect to one of the LAN ports on my router it will not register. I have a polycom on the same network that registers fine. I've tried with the polycom off and network and still get the same issue with the T46g.

I have my cable modem plugged into the WAN port on the router and the phone and other devices plugged into the LAN ports. The router has DHCP enabled is provides IPs to the rest of the devices. I do not have an external static IP address. The phone server I have is 3CX and it is running on Amazon EC2. As I said the polycom registers with no problem so there is something causing the T46g to not be able to register. I am not using any proxy server of any sort.

Any ideas would be appreciated.
Have you tried using the 3cx tunnel? Usually this overcomes any firewall/router issues.
Also check for the SIP ALG setting in the router...
I can't use the tunnel because I have a mac and no pc. I was able to get it to work though by adding the phone's IP to the DMZ in the router.

Thanks for your quick reply.
Reference URL's