Yealink Forums

Full Version: rport IP in SDP
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Is there anyway to get the T41p to use the IP address derived from rport in SDP? It works very nicely for Contact and VIA but phone still seems to send it's local IP in SDP.

I am referring to the following setting:
account.1.nat.rport = 2
Suggest that you can test the account.1.nat.rport = 1
Thanks for your reply.

account.1.nat.rport = 1 is worse. rport = 2 works most of the time. What I noticed is that if a user receives a call very fast after hanging up the previous one the audio does not connect. I can see in 3cx logs that the SDP is pointing to phone's local IP for those calls. If I turn on STUN it messes up the ports. Is there a way to tell the phone the NAT IP without port discovery?
How fast the serond incoming call will cause the problem.
Would you please send the 3cx log to me, and help us to get the syslog from phone side.
We can check something from them.
You can know how to do from the FAQ:

At the meantime, would you please tell me how many phones do you have?
How many of them have this problem?
Reference URL's