Yealink Forums

Full Version: bricked w52p - need recovery files
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

my phone is bricked and I cannot find the required W5X.rfs and W5X.bin files anywhere.

Anyone please?

Hi Daniel,

Have you tried to factory reset the phone first?

Please factory reset with following steps:
1. Disconnect power supply from base, but leave network cable connected
2. Long press Paging button on base, connect power supply, wait until all lights are on
3. Disconnect power, release Paging button, and reconnect power again
Hi Frank,

thanks for the hints. Unfortunately I cannot seem to get this station work again.

The factory reset does not work as much as I can tell.

* When I plug in power, only the lowest LED indicating power goes on. Network wise nothing happens, the station does not produce a single packet

* When I plug in and push the button before powering up, and holding, all LEDs go on in sequence, and the station sends out ARP requests from to

* If I present a host at the station wants to connect via TFTP

* If I present a TFTP server at it wants to download W5X.bin and W5X.rfs

* If I present those two files, it downloads them ok, then nothing happens anymore. The station does not request the W52P.bin.

The factory reset procedure provided above leaves me with the same behaviour: after powering it up again only the power LED goes on, no network, nothing.

Now I have seen multiple posts on the forum with similar problems, none have brought me any further. And actually here is part of my problem.

I cannot seem to be able to download the .rfs and .bin files from anywhere on the website. All I can find are either

* links to an FTP with an yealinkftp user and pw that do not work anymore
* links to an FTP with a login from an employee Cindy that gave out her login on the forum, but does not work anymore
* links to an FTP with a session-id kinda thing that worked only for one user
* posts from yealink folks sending the files via private messages to users
* links to users offering .rfs and .bin files hosted on Google drive or some other service I do not want to use and trust

Now I really don't get why those files are not just provided along the firmware in the download section. Wouldn't that be the proper way? Also, the recovery manual is something not readily available either. Not sure what the reason for this is. I have now tried to work with those files I found somewhere on the internet. They dont work, or maybe the phone is bricked -- see above. I cannot really verify it as I cannot even verify I have the correct files.

Happy about any input here, I was quite happy with the phone actually.

Hi Daniel,

Reading your post I suggest to send an email or PM to one of the Yealink forum admins and ask them if they know a solution for your issue.
I am sure they will respond to your question. Maybe they missed your post.
Yealink_James, Karl and Klaus are good guys.
bump thread because relevant for me
same issue here, need procedure too. Thanks for your help
Hi havellab,

did you, or anyone else, found out why station is not requesting for W52P.rom file after W5x.bin & W5x.rfs?
got the same issue ...

Reference URL's