Yealink Forums

Full Version: firmware update via config file
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm unable to get a T2x to upgrade firmware via the config file -
firmware.url = tftp://xxx.xxx.xxx.xxx/9.71.193.6.rom
Same with HTTP.

I've tried T20, T26 and T28

The tftp server logs show the phone pulling the file blocks successfully, but it never upgrades successfully.

It pulls the same file fine from a PC when entered in the GUI.

Does this work for anyone? Ideas?
Hi jdackert,

Can you tell me the current version of your phones?
Do you mean that you can upgarde them via webpage?
Please don't forget to add #!version:1.0.0.1 to your syntax.
---------------------------------------------------------
#!version:1.0.0.1

##File header "#!version:1.0.0.1" can not be edited or deleted, and must be placed in the first line.##
firmware.url = tftp://xxx.xxx.xxx.xxx/9.71.193.6.rom
---------------------------------------------------------
#!version:1.0.0.1 is the first line of the config file.

I recently tried from 2.72.0.25, 9.71.0.140 and 9.72.0.1

They do upgrade from webpage. I'd like to be able to upgrade phones at customer sites where I don't have GUI access to NAT'ed phones.
Hi jdackert´╝î

Please creat a teamviwer account that i can remote connect to your computer and give an private message to me a probable time that i can help you in site.
I found the problem - My tftp server was timing out the connection.
It works on a different tftp server
Thanks to your feedback.
The failure occurs because neither side resends the last Data (server) or ACK (Yealink) as suggested in the tftp RFC.
Reference URL's