Yealink Forums

Full Version: [W52P] SIP CANCEL with "Call completed elsewhere" shows missed call
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all,

I am running Asterisk 13.6 on FreeBSD using PJSIP. I have two Yealink W52H handsets on a W52P base and one Polycom SoundPoint IP 450.

I have an extension set to ring all three phones when dialed. When I dial that extension and I pick up any of the phones, the Polycom phone shows no missed call (as it should); however, both Yealink handsets log a missed call, but that shouldn't happen.

I verified using network traces that Asterisk did send the correct Reason: header with its CANCEL message, as shown below:

CANCEL sip:livingroom@;transport=TCP SIP/2.0
Via: SIP/2.0/TCP;rport;branch=z9hG4bKPjowr7UKfrONlOZR83eWjkaiTPRtHLSAIo;alias
From: "Poste salon" <sip:4012@>;tag=1XpNz2Ds--8dngCB9eQneaOh7SAbWJzu
To: <sip:livingroom@>
Call-ID: y.1DPWeUhfhN8ElX.u1zy77B.3Cz3jBr
CSeq: 16926 CANCEL
Reason: Q.850;cause=26
Reason: SIP;cause=200;text="Call completed elsewhere"
Max-Forwards: 70
User-Agent: Asterisk PBX 13.6.0
Content-Length: 0

I believe this is a bug, since I expected no missed call to be logged on the Yealink headsets, yet they do.

The Yealink W52P base is running firmware version Both handsets are running firmware version I can provide config.bin, syslog (level 6) logs and pcap traces on request.

Please help us to get the pcap and syslog and config.bin files, we can check something from them.
You can get more info from the link:
(02-19-2016 05:41 PM)Yealink_Karl Wrote: [ -> ]Please help us to get the pcap and syslog and config.bin files, we can check something from them.
You can get more info from the link:

Thanks! I have sent you these files by e-mail.

In the meantime I investigated this issue further. I noticed Asterisk sent two Reason headers:

(02-05-2016 01:41 AM)x0r Wrote: [ -> ]Reason: Q.850;cause=26
Reason: SIP;cause=200;text="Call completed elsewhere"

However, if I set up a SIP proxy which removes the "Reason: Q.850;cause=26" header, the call does no longer show up as a missed call, as intended.

So it seems that when there are multiple Reason headers in the same CANCEL message, the phone gets confused and this bug gets triggered.
I am seeing the exact same behavior with my T46G phones and Freepbx server. I can verify the extra "Reason: Q.850;cause=26" along with the "Reason: SIP;cause=200;text="Call completed elsewhere" messages.

Were you able to make any progress on the issue? Thanks.
I have a couple of T46G with FW and see the same behavior. Is there a solution by now?
The same problem with T48G and latest
Anyone have solution?
thanks best yealink support problem solved in V81 rom for t48
Tried it on T46G (FW problem not solved. Are there any configuration settings to change to get ist work? I also don't read anything about it in Release Notes.
Reference URL's