Yealink Forums

Full Version: Can't register T21P E2 phone
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, recently we bought sip phones. T41p and T21p E2. T41P works fine, but with another we have a bit problem, it wont register.
With same user and configuration i have no problem to register with T41p.

Here is some logs:
T41P:
SIP/2.0 401 Unauthorized
WWW-Authenticate: Digest realm="tel-sip.vno.local",qop="auth",opaque="1234567890abcedef",nonce="152844a639db51ff7f5a0387cd1ab3bd8d375d8d7ba",algorithm=MD5,stale=false
Call-ID: 2136429746@10.1.28.116
CSeq: 1 REGISTER

REGISTER sip:10.1.8.228:5060 SIP/2.0
Route: <sip:10.1.8.220:15060;lr>
P-Av-Transport: AP;fe=10.1.28.116:5062;ne=10.1.8.228:5060;tt=UDP
Via: SIP/2.0/UDP 10.1.8.228;rport;branch=z9hG4bK1902005302-AP;ft=10.1.8.228~13c4
Via: SIP/2.0/UDP 10.1.28.116:5062;branch=z9hG4bK1902005302
From: "**" <sip:1413@10.1.8.228>;tag=1022405090
To: "**" <sip:1413@10.1.8.228>
Call-ID: 2136429746@10.1.28.116
CSeq: 2 REGISTER
Contact: <sip:1413@10.1.28.116:5062>
Authorization: Digest username="1413", realm="tel-sip.vno.local", nonce="152844a639db51ff7f5a0387cd1ab3bd8d375d8d7ba", uri="sip:10.1.8.228:5060", response="b5c99b12d244b3590a96e647ce51edb8", algorithm=MD5, cnonce="0a4f113b", opaque="1234567890abcedef", qop=auth, nc=00000001

And we have some errors with T21P E2

Jan 27 18:44:24 sua [579]: FSM <4+warnin> [-01] Could not set header: www-authenticate: Digest realm="tel-sip.vno.local",qop="auth",opaque="1234567890abcedef",nonce="1528466a2d2913bf8015eecae34d5998eb6acf36fb8",algorithm=MD5,stale=false


Jan 27 18:44:24 sua [579]: SUA <6+info > [000] ****eCore event:(0x0002)ECORE_REGISTRATION_FAILURE ****
Jan 27 18:44:24 sua [579]: REG <6+info > [000] Register: get expires:3600
Jan 27 18:44:24 sua [579]: DLG <6+info > [000] authinfo: No WWW-Authenticate or Proxy-Authenticate
Jan 27 18:44:24 Log [629]: FWDD<6+info > FWD:account0 CFA:0 CFB:0 CFNA:0


Any solutions?
Would you please tell me the firmware of the T41 and T21 E2.
If possible, please send the log files to me, so I can check more.
Please email to me(karl@yealink.com). So I can check the issue more quickly.

It's better you can copy the problem in the email, so I don't need to check the forum again.
I have same problem. I update firmware to newest version: 52.84.0.15

Previous phone: W56P works fine with sam credentials to asterisk.

Phone is working over openvpn ad i can ping asterisk from it - vpn is set.

Below is my log:

[2019-02-07 19:30:05] DEBUG[21643]: chan_sip.c:9409 __find_call: = Looking for Call ID: 0_3045589603@192.168.90.6 (Checking From) --From tag 1543403549 --To-tag
[2019-02-07 19:30:05] DEBUG[21643]: chan_sip.c:28642 handle_incoming: **** Received REGISTER (2) - Command in SIP REGISTER
[2019-02-07 19:30:05] DEBUG[21643]: chan_sip.c:28667 handle_incoming: Ignoring SIP message because of retransmit (REGISTER Seqno 1, ours 1)
[2019-02-07 19:30:05] DEBUG[21643]: netsock2.c:172 ast_sockaddr_split_hostport: Splitting '192.168.90.6:5060' into...
[2019-02-07 19:30:05] DEBUG[21643]: netsock2.c:226 ast_sockaddr_split_hostport: ...host '192.168.90.6' and port '5060'.
[2019-02-07 19:30:05] DEBUG[21643]: netsock2.c:172 ast_sockaddr_split_hostport: Splitting '192.168.20.1:5060' into...
[2019-02-07 19:30:05] DEBUG[21643]: netsock2.c:226 ast_sockaddr_split_hostport: ...host '192.168.20.1' and port ''.
[2019-02-07 19:30:05] DEBUG[21643]: chan_sip.c:3753 __sip_xmit: Trying to put 'SIP/2.0 401' onto UDP socket destined for 192.168.90.6:5060
I m also facing same issue..Pls post the solution here..As i have tried asking on different page too but sadly didn't get any proper feedback.Thank you myschoolbucks
Reference URL's