Yealink Forums

Full Version: W52P Not pairing or responding
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
A strange one if anybody can help. I’ve got a W52P base and phone and all has been working fine for the last 14 months since I bought it from Ringcentral.
Today we’ve been decorating the office and unplugged the base to remove it. Since i’ve plugged everything back in, all that is happening is the power light is lit but nothing else happens. I’ve tried pressing the wireless button like the instructions say for a long time until you hear a beep. It just doesn’t respond. No sound, no other lights flashing. The network cable is in and it should be working, but again no lights other than power. I’ve tried switch everything off again but to no avail. I really need this working for the morning and just cannot work out why it should decide not to work since having a rest.

If anybody can shed any light or point me in the right direction it would really be appreciated.


Suggest that change network port and cable firstly.
If it does not work, would you please try hard reset with following steps
1.    Disconnect power from base.
2.    Press Paging button on base, at the meantime, connect with power supplier.​ You may find all the light lit one by one
3.    Release Paging button, disconnect power, connect power again.
Yes thanks for your help. I’ve tried everything. Ive tried different network ports and even tried changing the cable. I’ve tried resetting with the paging button pressed while plugging it in. All the lights light up one by one and then I unplug it, but again when I plug it in, just the power light is lit. Holding the paging button does nothing. It just doesn’t respond. Its only 13 months old.
I’ve been on to Ringcentral this morning, (UK) and they have tried to go through diagnostics, plugging the ethernet cable into my laptop but they say the ip address thats coming up for it is invalid. They are advising a brand new one.
If anybody has any more ideas before I have to shell out another £150 delivered I would be grateful.


I think the phone have hardware problem, you can contact with the distributor to replace the phone, it the phone still in warranty time.
No its about 14 months old now and i’ve been told its out of warranty

Are you as a customer not protected against this kind of guarantee periods? A guarantee period of two years applies to whole Europe, including the UK?
I was told by ring central that I was only covered by a 1 year guarantee. Just paid £140 inc shipping for the privilege.
Reference URL's