Yealink Forums

Full Version: Search in a remote directory
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey guys,

i have a problem with the remote directory. I can't use the search in it.

My remote directory is php-file which echos the xml code for the phone.
I can see every entry and everything is perfect, but as soon as i klick on the search button, the phone says: Entrys 0/0

The structure of the xml-directory is this:

Code:
<MenuItem>
<Name>John Doe</Name>
<URL>http://ulr.to.john.does.numbers</URL>
</MenuItem>

<DirectoryEntry>
<Name>Office</Name>
<Telephone>1234</Telephone>
</DirectoryEntry>

<DirectoryEntry>
<Name>Mobile</Name>
<Telephone>145542</Telephone>
</DirectoryEntry>

<DirectoryEntry>
<Name>Private</Name>
<Telephone>12363424</Telephone>
</DirectoryEntry>

I can't figure out how i get this to work.

Greetings,

Benny
hi Benny

for the search of the XML , it will search the XML phone book configured on the phone side but not through a php application

so it is advised to use the remote XML phone book instead , for more details , pleae refer to the FAQ below :

http://support.yealink.com/faq/faqInfo?id=232

BTW, i have submit your scenario to our PD for evaluation and advise them to optimized this feature in the future

TKS & BR

Michael;
Hi Michael,

thanks for the quick response.

Now i know what i can do.

Have a nice day,

Benny
Dude where is the xml code ? add this to here and close that tags too, sure you can getthe solutions


(12-17-2015 12:32 AM)benny Wrote: [ -> ]Hey guys,

i have a problem with the remote directory. I can't use the search in it.

My remote directory is php-file which echos the xml code for the phone.
I can see every entry and everything is perfect, but as soon as i klick on the search button, the phone says: Entrys 0/0

The structure of the xml-directory is this:

Code:
<MenuItem>
<Name>John Doe</Name>
<URL>http://ulr.to.john.does.numbers</URL>
</MenuItem>

<DirectoryEntry>
<Name>Office</Name>
<Telephone>1234</Telephone>
</DirectoryEntry>

<DirectoryEntry>
<Name>Mobile</Name>
<Telephone>145542</Telephone>
</DirectoryEntry>

<DirectoryEntry>
<Name>Private</Name>
<Telephone>12363424</Telephone>
</DirectoryEntry>

I can't figure out how i get this to work.

Greetings,

Benny
Reference URL's