Yealink Forums

Full Version: lang.gui = English in local cfg file
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I just upgraded to V73 for a lot of T46G. I really love the new "local conf" feature.

I have auto_provision.custom.protect=1, but I don't yet use the sync.
(auto_provision.custom.sync=0 )

I have the issue that the phone always adds "lang.gui = English" to the local conf file when autoprovisioning.

Even resetting the phone, or editing and reimporting the local config, doesn't help, as after reprovisioning, the local conf file always reads:

lang.gui = English

We are using the German language and the autoprovision file is setting

lang.wui = %%langwebUI%%
lang.gui = %%langlcdUI%%

which both are "German".

The local conf file is not saved on the server.

Is this a known issue? Or am I doing something wrong?
If the issue is known what is a temporary solution? I tested adding "lang.gui = German" to the local conf file (via the webinterface or the GUI) and this does work, the language stays German even after reprovisioning. But I will have to do this for each of the 250 phones, and we got some englisch or chinese speaking people here, too, so I don't want to overwrite their settings. And I will have to repeat the procedure for every new or completely resetted phone too. So I am looking of a more long-term solution.

best regards Frank

one more thing, that I noticed:
voice.ring_vol= ist not saved in the local config file?
Changes I make are not reflected in the file.
Why not? Can I configure it to be saved somehow?

I wanted to set the phones to autoprovision every day on during the night, but I cannot do this, if people have to readjust the ringer volume all the time. This would be a dealbreaker for me. Even doing a new provisioning once a month this way will really upset people here. Was this done on purpose because you don't want the "saving config file" message? I agree, that such a message would be irritating. But I would not mind it this much.
Is there anyway to disable the "saving local conf file" message completely? Users don't need to know, what is happening the background.

Best regards Frank

okay, there is a quite easy solution: I don't set the voice.ring_vol in the provisioning file at all. I would like to change it, because for desk phones, imho it is way to loud and already scared me several times, when "fresh phones" I just setup rang with the default volume. But as users can change it easily, it's okay.

I am planning to upload a wav with a lower level soon, anyway.

Still, I think it would be nice, if this was saved in local cfg, too.

Best regards

Reference URL's