Yealink Forums

Full Version: Basestation dropping offline, serving HTTP 500 errors after fw upgrade
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everyone

I have a W52P basestation with two w52h handsets. They were purchased in the UK in August 2014 and have worked fine until about 3 weeks ago. The basestation firmware was upgraded to when first purchased and the handsets were upgraded to immediately afterwards.

I went on holiday and when I came back around 3 weeks ago, I noticed my W52H handsets weren't ringing when a call came through (I also have a Cisco SPA303 on a different account and the server sends incoming calls to both). I checked the W52H handsets to find they were "searching for base" and the W52P basestation wasn't responding over the network.

I unplugged and then reconnected the power to the basestation, it came back online and the handsets reconnected. A day or so later the same thing happened again. The handsets would revert to searching for base and the basestation would be inaccessible on the network. I have since done this unplug/reconnect power thing on the basestation numerous times and it fixes the issue temporarily.

I noticed that there's an upgraded firmware here:

So I upgraded the basestation earlier today. Since then, when attempting to connect to the web GUI, I get the following message:

"500 - Internal Server Error"

Just connecting to the IP address (with no path), I get redirected to /servlet?p=login&q=loginForm&jumpto=status which after exactly 10 seconds returns "500 - Internal Server Error". Accessing that servlet URL directly returns the same error.

I performed a basestation reset using the handset and the problem persists. I also performed a factory reset by holding down the paging key, pulling the power and reconnecting it but I am still getting the internal server error.

Base FW: (upgraded today from
Base hardware: Can't check without access to GUI
Handset hardware:
Handset FW:

Can anyone please advise?

Since it is over a year old, is it suitable for return under warranty?

Please try to upgrade to the firmware of base and handset from the link below and test again.
And if you can't get access to the web GUI, please change other web browser and test again.
Hi Karl

As described, the web GUI is returning "500 - Internal server error" so I can't access the GUI. I have tried in 3 browsers. After disconnecting the power from the basestation and leaving it for 30 mins before connecting the power again, only the power indicator is lighting up on the basestation and it is not accessible at all over the network, though my router has DHCP lease for the basestation from earlier today and the network activity light for the basestation is lit on the switch. I will leave it for a few hours to see whether it comes back up.

Please try the hard reset the phone and try again.
1.    Disconnect power from base.
2.    Press Paging button on base, at the meantime, connect with power supplier.​ You may find all the light lit one by one
3.    Release Paging button, disconnect power, connect power again.
Hi Karl

Thanks for the instructions. I did as you described, the lights did come on in sequence. After disconnecting and reconnecting the power, the network light came on and I can see that the basestation got a DHCP lease but I still wasn't able to access the web interface on that address. I wasn't able to ping that address either. I have since powered it off/on several times but the network light is now not coming on and the device is not pingable on the DHCP address. I performed a hard reset again but the network light is still not coming on and the basestation is not pingable on the DHCP address. Undecided

Are you 100% sure that there is no second DHCP server in the network?
I had similar issues in a customer network with 2 DHCP servers active (accidentally).
No, there aren't any other DHCP servers. The only other device capable of serving DHCP is my WAP and DHCP is disabled on there. Besides which, none of my other devices are having problems getting a DHCP lease. Worth a shot though Smile

At this point, if I unplug the power from the basestation then reconnect it, the network light doesn't come on, even after a few hours, including after factory resetting, but the link light is lit on the switch (and goes out when I disconnect the basestation).
So I left the basestation powered off for the weekend, powered it on, no network comes up and my router doesn't have an active DHCP lease (there's no good reason for this, DHCP is working). It seems to me that it's dying so back to the original question, since it is over a year old but under two, is it suitable for return under warranty or do I have to buy another?
@ adsweet76:

If you have a Linux router, or you can setup a mirror port on your switch to monitor the traffic, there is a nice Linux tool available called "dhcpdump" at

That helped me to figure out the issue with the 2 active DHCP servers. Also very useful when working with provisioning.
I returned it under warranty in the end. Thanks for trying to help Smile
Reference URL's